LVM and VxVM

Replaced disk and now FS wont mount (HP-UX 11.11 U)

 
JC Santiago
New Member

Replaced disk and now FS wont mount (HP-UX 11.11 U)

I got 2 disk, c1t2d0 and c2t2d0. The latter is the new disk. The former got all the data. After a technician placed the new disk into the system, it doesnt seem to be recognizable.

c1t2d0 for the following FS:
/dev/vg01/lvol1
/dev/vg01/lvol2
/dev/vg01/lvol3

vgdisplay shows that the new disk "should" be part of the vg01:

--- Physical volumes ---
PV Name /dev/dsk/c1t2d0
PV Status available
Total PE 2170
Free PE 616
Autoswitch On
Proactive Polling On

PV Name /dev/dsk/c2t2d0
PV Status available
Total PE 2170
Free PE 2170
Autoswitch On
Proactive Polling On

In my /etc/fstab, the following are present:
# more /etc/fstab
# System /etc/fstab file. Static information about the file systems
# See fstab(4) and sam(1M) for further details on configuring devices.
/dev/vg00/lvol3 / vxfs delaylog 0 1
/dev/vg00/lvol1 /stand hfs defaults,nosuid 0 1
/dev/vg00/lvol4 /home vxfs delaylog,nosuid 0 2
/dev/vg00/lvol5 /opt vxfs delaylog 0 2
/dev/vg00/lvol6 /tmp vxfs delaylog,nosuid 0 2
/dev/vg00/lvol7 /usr vxfs delaylog 0 2
/dev/vg00/lvol8 /var vxfs delaylog 0 2
/dev/vg01/lvol1 /aa_opt vxfs defaults 0 3
/dev/vg01/lvol2 /aa_etc vxfs defaults 0 3
#/dev/vg01/lvol3 /aa_var vxfs delaylog,nosuid,largefiles 0 3
/dev/vg01/lvol3 /sc_var vxfs delaylog,largefiles 0 3

BDF shows:

# bdf
Filesystem kbytes used avail %used Mounted on
/dev/vg00/lvol3 204800 140520 63800 69% /
/dev/vg00/lvol1 298928 43144 225888 16% /stand
/dev/vg00/lvol8 3145728 2028528 1112768 65% /var
/dev/vg00/lvol7 2097152 1319328 771784 63% /usr
/dev/vg00/lvol6 1302528 629800 667504 49% /tmp
/dev/vg00/lvol5 3145728 2698352 443936 86% /opt
/dev/vg00/lvol4 1048576 891504 156072 85% /home

I tried to mount the FS using mount -a, but got the following errors:

vxfs mount: not a valid vxfs file system
vxfs mount: not a valid vxfs file system
vxfs mount: not a valid vxfs file system

--> the error above is for the vg01/lvol* FS

How can I force the system to recognise the old mount points and FS located in c1t2d0 without loosing all the data inside it? I tried to remove the /etc/mnttab and do a mount -a again, but still the same. Restarting the system doesnt help as well.

It is critical that the data inside disk c1t2d0 will be kept. In the end, I want both disk to be mirrored.

Thanks in advance.


5 REPLIES 5
cjb_1
Trusted Contributor

Re: Replaced disk and now FS wont mount (HP-UX 11.11 U)

Are you implying these two disks were previously mirrored and you want to get to that state again?

If so you should consult the 'when good disks go bad' bible.

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c01911837/c01911837.pdf
Torsten.
Acclaimed Contributor

Re: Replaced disk and now FS wont mount (HP-UX 11.11 U)

The disk is still empty:

Total PE 2170
Free PE 2170

Use lvdisplay -v /dev/vg01/lvol...

to see if it should be mirrored.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JC Santiago
New Member

Re: Replaced disk and now FS wont mount (HP-UX 11.11 U)

hi cjb - thanks for the link, very helpful indeed...

hello torsten - yep, new disk is still empty. my worries is the old disk:

PV Name /dev/dsk/c1t2d0
PV Status available
Total PE 2170
Free PE 616
Autoswitch On
Proactive Polling On


The logical volumes are still mapped to the PV however, not able to mount. I am afraid that all the data inside are lost. :-(
Torsten.
Acclaimed Contributor

Re: Replaced disk and now FS wont mount (HP-UX 11.11 U)

A new disk is empty - of course.


Question is, was it mirrored???


-> lvdisplay -v


and

vgdisplay -v vg01

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
JC Santiago
New Member

Re: Replaced disk and now FS wont mount (HP-UX 11.11 U)

as requested:

# lvdisplay -v /dev/vg01/lvol1
--- Logical volumes ---
LV Name /dev/vg01/lvol1
VG Name /dev/vg01
LV Permission read/write
LV Status available/syncd
Mirror copies 0
Consistency Recovery MWC
Schedule parallel
LV Size (Mbytes) 2336
Current LE 146
Allocated PE 146
Stripes 0
Stripe Size (Kbytes) 0
Bad block on
Allocation strict
IO Timeout (Seconds) default

--- Distribution of logical volume ---
PV Name LE on PV PE on PV
/dev/dsk/c1t2d0 146 146

# vgdisplay -v /dev/vg01
--- Volume groups ---
VG Name /dev/vg01
VG Write Access read/write
VG Status available
Max LV 16
Cur LV 3
Open LV 3
Max PV 16
Cur PV 2
Act PV 2
Max PE per PV 2500
VGDA 4
PE Size (Mbytes) 16
Total PE 4340
Alloc PE 1554
Free PE 2786
Total PVG 0
Total Spare PVs 0
Total Spare PVs in use 0

--- Logical volumes ---
LV Name /dev/vg01/lvol1
LV Status available/syncd
LV Size (Mbytes) 2336
Current LE 146
Allocated PE 146
Used PV 1

LV Name /dev/vg01/lvol2
LV Status available/syncd
LV Size (Mbytes) 2048
Current LE 128
Allocated PE 128
Used PV 1

LV Name /dev/vg01/lvol3
LV Status available/syncd
LV Size (Mbytes) 20480
Current LE 1280
Allocated PE 1280
Used PV 1


--- Physical volumes ---
PV Name /dev/dsk/c1t2d0
PV Status available
Total PE 2170
Free PE 616
Autoswitch On
Proactive Polling On

PV Name /dev/dsk/c2t2d0
PV Status available
Total PE 2170
Free PE 2170
Autoswitch On
Proactive Polling On