LVM and VxVM

The HP-UX kernel running on this system does not provide this feature.

 
Prathap Krishna
Occasional Advisor

The HP-UX kernel running on this system does not provide this feature.

Getting below error after a reboot os new server 11.23 rx6600. Please let me know any resolution for the same..
gchange: Warning: Couldn't attach to the volume group physical volume "/dev/dsk/c6t0d0":
The HP-UX kernel running on this system does not provide this feature.
Install the appropriate kernel patch to enable it.
.
7 REPLIES 7
Steven E. Protter
Exalted Contributor

Re: The HP-UX kernel running on this system does not provide this feature.

Shalom,

A physical volume /dev/dsk/c6t0d0 is configured in one of your volume groups:

To see which one:
strings /etc/lvmtab

That disk is no longer available, hence the error. This is not something you fix with a patch. This is something you fix by diagnosing and correcting the problem.

The disk probably needs to be replaced.

After replacement or the determination that nothing important was on it:

mv /etc/lvmtab /etc/lvmtab -a

vgscan -a

Now the error is gone. You may need to run vgreduce -f and follow post instructions depending on the nature of the failure.

http://docs.hp.com/en/5992-3385/5992-3385.pdf

More complete guide to these issues.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Prathap Krishna
Occasional Advisor

Re: The HP-UX kernel running on this system does not provide this feature.

there was 4 paths for once the lun was asigned from 2 fc cards. and currently only two are active. the rest shows unavailable. All 4 paths were good while creating FS. issue happeded after reboot. Need to know whether is this issue with storage side (clarion) or issue with kernel tuning/patches.
Avinash20
Honored Contributor

Re: The HP-UX kernel running on this system does not provide this feature.

Check in ioscan if you are able to see the PV's

Also check if there is any issue with FC cable
"Light travels faster than sound. That's why some people appear bright until you hear them speak."

Re: The HP-UX kernel running on this system does not provide this feature.

Prathap,

"The HP-UX kernel running on this system does not provide this feature. Install the appropriate kernel patch to enable it"

You get this message when you have installed the LVM Online Replacement (OLR) commands Patch (PHCO_31709 or one of the patches that supersede it), without installing the LVM OLR kernel patch (PHKL_32095 or one of the patches that supersede it).

So Identify the patch in question on your system and install the co-requisite.

I'm not sure how you will have done this as the corequisite patch requirement should have generated an error/warning when you installed the commands patch.

HTH

Duncan

I am an HPE Employee
Accept or Kudo
sdass
Advisor

Re: The HP-UX kernel running on this system does not provide this feature.

I think system is not able to see the LUNS through one FC card, we too had the same issue once and we were not able to activate the VG what we had done iswe exported the VG and imported with the remaining path and every starts working fine
Prathap Krishna
Occasional Advisor

Re: The HP-UX kernel running on this system does not provide this feature.

Thank you. after checking found issue with the naviagent configuration file , where "OptionsSupported AutoTrespass" was commneted from config file of naviagent, /opt/Navisphere/bin/agent.config
Ben Dehner
Trusted Contributor

Re: The HP-UX kernel running on this system does not provide this feature.

I had a system (RX6600/HP-UX 11.23) running Service Guard demonstrating the same symptoms. In addition, ioscan showed all of my SAN-attached disk (EMC Clariion) as state "NO_HW", not available. However, I could still activate the volume groups and mount file systems.

The problem was, as Prathap described, with the Navisphere agent configuration file. The functional copy is in "/etc/Navisphere/agent.config"; /opt/Navisphere only contains the template. After un-commenting the AutoTresspass option and restarting the Navisphere agent, ioscan showed everything as "CLAIMED", and the volume groups activated without error.
Trust me, I know what I'm doing