LVM and VxVM
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Activate VG01 | Smart Array logical drive failed

 
Aamir_Majeed
Advisor

Unable to Activate VG01 | Smart Array logical drive failed

Hi,

 

We have VG01 on HP-UX 11.31 server, it is created on MSA 30 JBOD connected via Smart Array 64000 controller.

 

We have 2 logical drives as mentioned below;

---- LOGICAL DRIVE SUMMARY ---------------------------------------------------

# RAID Size Status

0 1+0 286097 MB FAILED

1 1+0 286097 MB RECOVERING

 

---- SCSI DEVICE SUMMARY -----------------------------------------------------

Location Ch ID Type Capacity Status

external 1 0 DISK 300.0 GB OK

external 1 1 DISK 300.0 GB OK

external 1 2 DISK 300.0 GB OK

external 1 3 DISK 300.0 GB OK

 

Both of these logical drives are part of  Volume group VG01;

 

# strings /etc/lvmtab

/dev/vg00

/dev/disk/disk3_p2

/dev/dsk/c2t1d0s2

/dev/vg01

M>q7

/dev/dsk/c4t0d0

/dev/dsk/c4t0d1

 

disk 6 0/2/1/0/4/0.0.0 sdisk CLAIMED DEVICE HP LOGICAL VOLUME /dev/dsk/c4t0d0 /dev/rdsk/c4t0d0

disk 7 0/2/1/0/4/0.0.1 sdisk CLAIMED DEVICE HP LOGICAL VOLUME /dev/dsk/c4t0d1 /dev/rdsk/c4t0d1

 

Please note both of the logical HDDs are showing claimed status, I am susspecting /dev/dsk/c4t0d0 as one Logical Drive is shown Failed.

 

Is it possible to activate VG01 without this PV.

 

Thanks and Regards,

 

Aamir Majeed.

13 REPLIES 13
Torsten.
Acclaimed Contributor

Re: Unable to Activate VG01 | Smart Array logical drive failed

If the LVOLs are not mirrored at LVM level you need all the PVs present.

Find out the controllers /dev/ciss_ device and send a

# sautil /dev/ciss_

# saconfig /dev/ciss_


The status of FAILED doesn't looks good - any disks replaced???

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Aamir_Majeed
Advisor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Hi,

 

Yes, LVOLs are not mirrored at logical level, Please find the attached output; and also please tell me how to assign points on replies, as I am not able to see any option.

 

Thanks,

Aamir Majeed.

Torsten.
Acclaimed Contributor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Please send


# saconfig /dev/ciss4

# ioscan -fn

# vgdisplay -v vg01

# strings /etc/lvmtab

Any disks already replaced?

To assign points click the white KUDOS! start in the left column.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Unable to Activate VG01 | Smart Array logical drive failed

logical drive 0 consists of disk 0 and 1.

both were "REMOVED IN HOT PLUG" - now FAILED

logical drive 1 consists of disk 2 and 3.

disk 2 was also REMOVED IN HOT PLUG and is now RECOVERING.



Looks like you pulled all 3 disks online and now you have a destroyed logical drive!

What have you done?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Aamir_Majeed
Advisor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Actually, mentioned setup is installed at customer site. As per customer there were amber LEDs on 3 disks, before considering any thing he power cycled disk enclosure and rebooted server.

 

Now he called us, to look into issue.

 

Currently we are unable to activate VG01.

 

Disks are showing green LED now, and also we are able to see both drives as claimed status

 

and also diskinfo is showing proper information, but dd is showing errors on one logical drive please find attachment for further output.

 

Also note we are getting proper results when we

 

At the moment my question is how we can activate Vg01, and is there any way that we can recover those disks.

 

 

 

Aamir_Majeed
Advisor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Sorry, missed log file.

Torsten.
Acclaimed Contributor

Re: Unable to Activate VG01 | Smart Array logical drive failed

I'm absolutely sure the disks 0,1 and 2 were pulled.

While disks 0 and 1 were pulled, the array did not have any disks left, hence it is failed.

Disk 2 was also pulled, currently the array synchronizes disk 3 to disk 2 (REBUILDING).


Is this a Itanium server?


Consider to reboot the server, watch out for smartarray messages on the console during boot.


You did not post the requested information yet.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Aamir_Majeed
Advisor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Yes this is rx4640 Itanium server, and also status has been changed to OK of Raid group 1 which was previously rebuilding.

 

Is there any way to activate this VG01 with only one PV.

Aamir_Majeed
Advisor

Re: Unable to Activate VG01 | Smart Array logical drive failed

Please refer to my previous post, I have attached file named ems.log.

 

It contains required information except Vgdisplay as I cannot get this info as VG is not active.