Volume Group not activated

 
SOLVED
Go to solution
Carlos Munoz Lopez
Frequent Advisor

Volume Group not activated

Hi guys! I'm having problems with three volume groups, they are not activated when I rebooted the system, I tried to mount the file system and it's not successful, I tried to view the VG with vgdisplay, and it doesn't show them. I have installed on this server MC/Service Guard, but the file systems that form part of the cluster, they don't have any problem, the problem is with the rest of the filesystems created in the server. I would like some help. Something strange is that one file system that is not part of the cluster is mounted. I don't why this is happening. I need some help on solving this problem
4 REPLIES 4
Steven E. Protter
Exalted Contributor

Re: Volume Group not activated

There has got to be something wrong here, but an error response is needed to figure it out.

Try this command:

vgchange -a y /dev/vg01

Change the volume group to the proper vg. You should get an error that will begin the investigative process.

Post the error.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Sridhar Bhaskarla
Honored Contributor

Re: Volume Group not activated

Hi,

There are couple of things to check.

1. Check your /etc/lvmrc and make sure AUTO_VG_ACTIVATE is set to 1. If it is 0 (some admins do it if the VGs are part of serviceguard) then unless it is specified in /etc/lvmrc, no vg except vg00 will be activated.

2. Do a "vgchange -a y vgname". If it gives an error saying that the specified mode conflicts with the configured mode, then it means that vg is part of serviceguard. You will need to run "vgchange -c n vgname" to mark the VG as not part of the cluster. However, to do so, you will need to have cluster daemons running. So, you will have to bring up the cluster temporarily.

3. If only few filesystems are not getting mounted, then check /etc/fstab to see if they are mentioned there. Also look at /etc/rc.log for errors on mounting the filesytems.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
kamal_9
Super Advisor
Solution

Re: Volume Group not activated

hi
pls give the output of
vgdisplay -v /dev/vgname &
vgchange -a y /dev/vgname and
pls check the harddisk is getting sensed in ioscan -fnC disk
T. M. Louah
Esteemed Contributor

Re: Volume Group not activated

During boot errors generated while calling startup scripts will be recorded in /etc/rc.log, now simply run:
# mv /etc/lvmtab /etc/lvmtab.old
# vgscan -v
if there is a disk problem vgscan will report it, a new lvmtab will be created you can compare it to /etc/lvmtab.old, by:

# strings /etc/lvmtab

cheers,
Little learning is dangerous!