LVM and VxVM
Showing results for 
Search instead for 
Do you mean 

Warning: Max_PE_per_PV for the volume group

SOLVED
Go to Solution
Regular Advisor

Warning: Max_PE_per_PV for the volume group

#vgcreate vg02 /dev/dsk/c6t0d1
Warning: Max_PE_per_PV for the volume group (65535) too small for this PV (166911).
Using only 65535 PEs from this physical volume.
Increased the number of physical extents per physical volume to 65535.
vgcreate: Volume group "/dev/vg02" could not be created:
VGRA for the disk is too big for the specified parameters. Increase the
extent size or decrease max_PVs/max_LVs and try again.

 

Getting the above error message, Any Help would be highly appreciated

1 REPLY
Highlighted
Honored Contributor

Re: Warning: Max_PE_per_PV for the volume group

You likely need to add some additional parameters to your vgcreate command.

 

Here is what I would do:

 

# vgcreate -s 64 -l 10 -p 12 vg02 /dev/dsk/c6t0d1

 

What these do:

 

-s 64 --- sets the PE size at 64 MB (default is 4 MB, maximum is 256 MB)

-l 10 --- allows for 10 LV's to be defined in this VG (the number you choose should be appropriate for your environment - the default is 255, which is the maximum)

-p 12 --- allows for 12 physical volumes in the VG (the number you choose should be appropriate for your environment - the default is 16)

For more information on the various options, see the 'vgcreate' man page.

 

 

You may be able to create your VG by specifying a new value for the PE size only.  Something like:

 

# vgcreate -s 64 vg02 /dev/dsk/c6t0d1

 

If you still have problems and receive an error, try increasing the value of the '-s' option.  Be aware that it must be specified in powers of 2, so the  next values after 64 are 128 & 256.