LVM and VxVM
cancel
Showing results for 
Search instead for 
Did you mean: 

attach HP-UX 11.23 to EVA6400, server does not see LUN

 
SOLVED
Go to solution

attach HP-UX 11.23 to EVA6400, server does not see LUN

I'm trying to attach an HP-UX 11.23 server to a LUN on an EVA6400.  This server is already attached to an existing EVA8000 with several LUN's presented.

 

I ran "ioscan -fnC disk", and it appears that the server sees the disk on the 6400:

*************************************************

disk 132 0/4/1/0.12.0.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
/dev/dsk/c8t0d1 /dev/rdsk/c8t0d1


disk 131 0/4/1/0.12.14.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
/dev/dsk/c30t0d1 /dev/rdsk/c30t0d1


disk 133 0/4/1/1.22.0.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
/dev/dsk/c32t0d1 /dev/rdsk/c32t0d1

 

disk 134 0/4/1/1.22.14.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
/dev/dsk/c34t0d1 /dev/rdsk/c34t0d1

*************************************************

 

Then I run insf -e, and I can see that the server installs the drivers for the disks it sees during the ioscan:

 

insf: Installing special files for sdisk instance 132 address 0/4/1/0.12.0.0.0.0.1
insf: Installing special files for sdisk instance 133 address 0/4/1/1.22.0.0.0.0.1
insf: Installing special files for sdisk instance 134 address 0/4/1/1.22.14.0.0.0.1
insf: Installing special files for sdisk instance 131 address 0/4/1/0.12.14.0.0.0.1

*************************************************

 

Then I run "autopath discover" which says it's successful

 

But when I run "autopath display", the server does not see the new disk.

 

autopath display -c  and -r   tell me that the server does not see the array controller on the 6400 (it only sees the existing array.

 

Not sure what's wrong here.

 

Thank you,

 

5 REPLIES 5
Henry Fauni
Valued Contributor

Re: attach HP-UX 11.23 to EVA6400, server does not see LUN

Instead of just  "ioscan -fnC disk", try running ioscan with

 

# ioscan -f

 

followed by:

 

#  insf -e

 

then

 

# autopath discover

Re: attach HP-UX 11.23 to EVA6400, server does not see LUN

I got the same result.  ioscan -f gives me:

 

Channel Adapter (FC Port 1)
fcp 0 0/4/1/0.12 fcd_fcp CLAIMED INTERFACE FCP Domain
ext_bus 8 0/4/1/0.12.0.0.0 fcd_vbus CLAIMED INTERFACE FCP Array Interface
target 50 0/4/1/0.12.0.0.0.0 tgt CLAIMED DEVICE
ctl 30 0/4/1/0.12.0.0.0.0.0 sctl CLAIMED DEVICE HP HSV400
disk 132 0/4/1/0.12.0.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
ext_bus 29 0/4/1/0.12.0.255.0 fcd_vbus CLAIMED INTERFACE FCP Device Interface
target 49 0/4/1/0.12.0.255.0.0 tgt CLAIMED DEVICE
ctl 28 0/4/1/0.12.0.255.0.0.0 sctl CLAIMED DEVICE HP HSV400
ext_bus 9 0/4/1/0.12.3.0.0 fcd_vbus CLAIMED INTERFACE FCP Array Interface
target 11 0/4/1/0.12.3.0.0.0 tgt CLAIMED DEVICE

 

 

Channel Adapter (FC Port 2)
fcp 1 0/4/1/1.22 fcd_fcp CLAIMED INTERFACE FCP Domain
ext_bus 32 0/4/1/1.22.0.0.0 fcd_vbus CLAIMED INTERFACE FCP Array Interface
target 53 0/4/1/1.22.0.0.0.0 tgt CLAIMED DEVICE
ctl 32 0/4/1/1.22.0.0.0.0.0 sctl CLAIMED DEVICE HP HSV400
disk 133 0/4/1/1.22.0.0.0.0.1 sdisk CLAIMED DEVICE HP HSV400
ext_bus 33 0/4/1/1.22.0.255.0 fcd_vbus CLAIMED INTERFACE FCP Device Interface
target 54 0/4/1/1.22.0.255.0.0 tgt CLAIMED DEVICE
ctl 34 0/4/1/1.22.0.255.0.0.0 sctl CLAIMED DEVICE HP HSV400
ext_bus 17 0/4/1/1.22.3.0.0 fcd_vbus CLAIMED INTERFACE FCP Array Interface
target 29 0/4/1/1.22.3.0.0.0 tgt CLAIMED DEVICE

 

 

 

 

Then insf and 'autopath discover' and 'autopath display' give me the same result. I see no new disk to configure, unless I am missing something.

 

Thank you.

Henry Fauni
Valued Contributor

Re: attach HP-UX 11.23 to EVA6400, server does not see LUN

Does "autopath -r" lists both arrays?

 

Actually the EVA8000 is older than EVA6400. What is your SecurePath version? It's quite possible you may need to upgrade to the latest version. I think 3.0F SP4 is out now.

Torsten.
Acclaimed Contributor
Solution

Re: attach HP-UX 11.23 to EVA6400, server does not see LUN

see

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=de&cc=de&prodTypeId=18964&prodSeriesId=471465&swItem=co-73520-1&prodNameId=1825336&swEnvOID=7&swLang=13&taskId=135&mode=4&idx=0

 

 

What's new with Secure Path 3.0F SP4 for Active-Active disk arrays

 

...

Provides support for Logical Units presented from HP StorageWorks disk arrays EVA6400/EVA8400

 

 

 

 

 

 

 

So the older version is not aware of the EVA6400 model.

 


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted

Re: attach HP-UX 11.23 to EVA6400, server does not see LUN

Looks like we are on SecurePath3.0 sp2, if I read correctly. Thank you for the information!

 

autopath display -r shows only the existing 8000 array.