fbackup/frecover ACL issues

 
Prasanth Thomas
Valued Contributor

fbackup/frecover ACL issues

Hello All,

We have a strange problem on the HPUX 11.31 (September Release 2008) Base Operating Envrionment.

VxFS Version: 4.1 (Base Version)
vpar environment

HPUX11i-BOE B.11.31.0809 HP-UX Base Operating Environment

HP-UX B.11.31 U 9000/800

The system is producing the following error when we run the batch script of performing some operation where it sets the ACLs for the files depending on the output of command "groups -p"

After changing the ACLs it uses fbackup/frecover method to sync the files with the another server which is similar version and release.

One more strange factor here is, if i run the same script manually it works perfectly without any errors.

Error (Only in the heavy loads are running or runs in the batchload):
========================
unknown user or group specified in the ACL for file :/xxx/xxx ; optional entries are not backed up.

Findings:
========
=> System is a NIS client / Slave server too for the same version of NIS server.

=> Since it works intermittantly not sure of the configuration issue.

=> Setacl operation happens on the VxFS file system mounts.

=> I can understand the fbackup not backing up the ACLs. but unable to go back and find the RCA for the same.

I am not sure if we have any patches needs to be installed or the places which we need to check back.

There are lots of things are involved here to suspect on

=> NIS ?
=> VxFS 4.1?
=> fbackup/frecover
=> ACLs issue on VxFS 4.1?

Please provide me some light to go ahead on this.

It is really failing lots of batch jobs and we have to run manaully.

Thank you,
Regards,
Prasant
3 REPLIES 3
Dennis Handly
Acclaimed Contributor

Re: fbackup/frecover ACL issues

I assume by the time you see the error message and try listing the ACLs, it is fine? How may hours have gone by?
Would it make sense to have some automation scan for this error right away and check?
Prasanth Thomas
Valued Contributor

Re: fbackup/frecover ACL issues

Hi,

Thanks for the response. It is not setting the ACLs at all. It just copies the file without ACLs.

I have also inserted my custom script to perform the ACL change on some dummy file during the automation, it also fails with the same error but file is being copied without ACLs.

For temporary checking purpose, i have copied the relevant accounts to the local password file. No errors are reported till now

if this goes fine permanently, then we need to understand that ACLs intermittant problems duirng the heavy load and it is not able to fetch the NIS mapped accounts quickly.

Thank you!
Steven E. Protter
Exalted Contributor

Re: fbackup/frecover ACL issues

Shalom,

=> NIS ?
Unlikely the ACL files should still be backed up.
=> VxFS 4.1?
Yes, look in the patch database for patches covering ACL issues
=> fbackup/frecover
Search the patch database for this topic and ACL
=> ACLs issue on VxFS 4.1?
Redundant to above issue.

This might be covered by installing a recent QPK for the OS, but I'd actually want to do some research in the patch database to find something specific.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com