cancel
Showing results for 
Search instead for 
Did you mean: 

file system corrupted

 

file system corrupted

Hello ,

I have old system hpux 10.20
and there is vxfs file system corupted , and I tried to fix the file system ,
by 1-# fsck -F vxfs -o full,nolog /dev/vg01/rlvol1

but this gives the error message:
fsck read failure bno=7799544 , off=0 , len=8192.
2- I tried to fix file system by fsdb command
but I am not familiar with fsbd.

Please can anyone to tell me how to solve this problem , or how to use fsdb command ?


Thanks

2 REPLIES 2
Calandrello
Trusted Contributor

Re: file system corrupted

dear
fsck -F vxfs -o full /dev/vg01/rlvol1
Bill Hassell
Honored Contributor

Re: file system corrupted

The problem is not fixable. fsck only fixes pointers and structural errors. The read error means that the disk has errors and cannot read the sectors. You will probably see additional errors in syslog.log. fsdb allows you change the values on the disk but cannot read (or write) anything to the bad areas of the disk. Even if you could write data to the disk, you would need a lot of documentation about the VxFS filesystem which is proprietary to Veritas.

Time to use the backup tapes to restore the bad filesystem (after replacing the disk).


Bill Hassell, sysadmin