fsadm and SAM

 
Alec B. Toting
Occasional Contributor

fsadm and SAM

hi hope someone can help me on this. heres my situation.

i have a file system "/u05"
on vxfs. I wanted to convert it to handle large files so
i did a umount /u05 and fsadm -F vxfs -o largefiles /dev/vg05/lvol1

i get this error "vxfs fsadm: /dev/xpvg10/lvol1 is not the root inode of a vxfs file sytem"

then i tried using SAM to convert /u05 to largefiles..
SAM-> disks n filesystems -> filesystems -> action -> modify - allow large files and it worked! i was wondering what specific command SAM used to make the conversion possible.

thanks in advance
and HPUX keeps on runnin
9 REPLIES 9
Giada Bonfà
Frequent Advisor

Re: fsadm and SAM

Hi,

You don't have to umount the file system.
You should just do:

fsadm -Fvxfs -o largefiles /u05

good luck
Donald Kok
Respected Contributor

Re: fsadm and SAM

Hi,

the error and the command mention a different vg. was this a typo?
Donald
My systems are 100% Murphy Compliant. Guaranteed!!!
Tom Geudens
Honored Contributor

Re: fsadm and SAM

Mmm,
To see what sam did, check /var/sam/log/samlog

Hope you'll find it,
Tom
A life ? Cool ! Where can I download one of those from ?
john korterman
Honored Contributor

Re: fsadm and SAM

Hi,
I think I once got the same error and tried specifying the raw device insted: in your case it would have been /dev/vg05/rlvol1,
but you can check what sam did by looking in:/var/sam/log/samlog

However, when you have converted a filesystem to "largefiles" then check that your mount options for the filesystem are ok in /etc/fstab; it should say "largefiles" instead of "nolargefiles" for the file system in question, else it cannot be mounted again, e.g. when you boot.

regards,
John K.

inst
it would be nice if you always got a second chance
T G Manikandan
Honored Contributor

Re: fsadm and SAM

The nolargefiles option in the /etc/fstab is over-riding.

Please change that to largefiles


Thanks
KO kwang tae
Advisor

Re: fsadm and SAM

when you are changing to largefiles, i think you have to umount, unless installing ONline JFS.

check inode use rate

# glance -t

or
# bdf -i

if you use more than 100% inode, change kernel parameter :inode
Jeff Carlin
Frequent Advisor

Re: fsadm and SAM

Hopefully by now you have already got your answer. Otherwise you are missing the "r" for the raw device in the lv_path. Your command should look like this:

fsadm -Fvxfs -o largefiles /dev/vg05/rlvol1

I know, fsadm should really tell you that the device is a block device instead of some criptic "root inode" error.

To verify your change, use the command:

fsadm -Fvxfs /dev/vg05/rlvol1

you should see "largefiles".

Remember to change your /etc/fstab and include "largefiles" on the line for this filesystem.

Jeff
Where wisdom is called for, force is of little use. --Of course, a hammer does wonders for relieving stress.
Paul Sperry
Honored Contributor

Re: fsadm and SAM

Changing the largefiles flag may require changes to /etc/fstab. For
example, if fsadm is used to set the largefiles flag, but nolargefiles
is specified as a mount option in /etc/fstab, the files system is not
mountable.
Suresh Patoria
Super Advisor

Re: fsadm and SAM

HI,

You sure about the Volume Group beacuse you mention vg05

By default root logical volume lvol1 lies in /dev/vg00

pls check this then try the fsadm command

can you put the bdf output pls