ioscan showing NO_HW in scan

 
SOLVED
Go to solution
Daryl Rose
Advisor

ioscan showing NO_HW in scan

Hello,

I just had several LUNs pulled away from some of the servers, HP-UX 11.23. None of these LUNs were being used and were not in any volume groups. I thought that after the LUNs were pulled away, I would be able to do an ioscan -fnC disk, and that I would no longer see them. I must be missing a step, but I'm not sure what. Can someone please tell me what I need to do to remove these devices?

Thank you.

Daryl
6 REPLIES 6
H_16
Trusted Contributor

Re: ioscan showing NO_HW in scan


If you use the rmsf command this will remove the relevant device files.

Daryl Rose
Advisor

Re: ioscan showing NO_HW in scan

I remember now. I don't do as much in HP as I would like, and I had forgotten about that command.

Thank you.

Daryl
H_16
Trusted Contributor
Solution

Re: ioscan showing NO_HW in scan

Some points would be nice..
Tim Nelson
Honored Contributor

Re: ioscan showing NO_HW in scan

here is a quick way to take care of them all at once

ioscan with no args first to make sure you have current info.

then

ioscan -kfnC disk|awk '/NO_HW/ {print $3}'|while read list do
rmsf -H $list
done



Daryl Rose
Advisor

Re: ioscan showing NO_HW in scan

Thanks Tim, I'll have to add that to my little bag of tricks. I'm sure I'll need to use that in the future at some point.

Daryl
SunnyS
Advisor

Re: ioscan showing NO_HW in scan

while we are on the subject, in 11.31, you can do just "rmsf -x" and it gets rid of all stale nodes.