LVM and VxVM

vgchange -a n return device busy

 
Jonathan Caplette_1
Super Advisor

vgchange -a n return device busy

hi guys,

I tried to deactivate a VG that as been tried to mount a lvol...

when I do a vgchange -a n vg01PA i got this:
# vgchange -a n vg01PA
vgchange: Couldn't deactivate volume group "vg01PA":
Device busy

I've this process that I can't kill:
root 22937 1 0 07:29:17 ? 0:00 /sbin/fs/vxfs/mount -Fvxfs -orw,nosuid,largefiles /dev/vg01PA/l

How can I kill this and be able to deactivate my VG?

jonathan
7 REPLIES 7
James R. Ferguson
Acclaimed Contributor

Re: vgchange -a n return device busy

Hi Jonathan:

If a 'kill -9' won't terminate the mount process then you will need to reboot.

A 'kill -9' signal will not be acted upon if the kernel is waiting for an I/O to complete -- which would certainly appear to be the case.

Regards!

...JRF...
Jeeshan
Honored Contributor

Re: vgchange -a n return device busy

Dear jonathan

use this command in the mount point of that volume group

fuser -ku /

it will kill the user or process at once and then u can deactivate the vg.

Jeesun
a warrior never quits
skt_skt
Honored Contributor

Re: vgchange -a n return device busy

do you know any changes happened to the disks belong to this VG when the VG is active; like vgchgid. vgid can get changed when those disks went through a BCV sync(by mistake) when the VG is active.In those scenario vgcfgrestore from source server (using *.conf taken from source) could help w/o a reboot. I have gone through this while a new VG is adding to the cluster but with NO PROD DATA.

Assuming you already made sure there is no process using this VG.

Mridul Shrivastava
Honored Contributor

Re: vgchange -a n return device busy

Could you let us know exactly what happened and then why u r trying to deactivate this VG. It is clearly seen that mount request is pending on this lvol and that is not completed may be because of I/O.. if that is the case then you will not be able to kill the process and as a last option u may have to reboot the box.

Time has a wonderful way of weeding out the trivial
Gary L. Paveza, Jr.
Trusted Contributor

Re: vgchange -a n return device busy

This is a known "issue" with vgchange. Prior to doing a vgchange try issuing a vgsync /dev/vg???. That should clear the problem.
Jonathan Caplette_1
Super Advisor

Re: vgchange -a n return device busy

Thanks you all..

I had to reboot the box...

Sorry for the late answer from me... My problem was because this VG is used in a SG environement... This is used with SAN disk and TrueCopy ... The problem is when I used to try running my package on second node, my SG script didn't do the takeover from TrueCopy... so this server tried to mount filesystems with no write permission on it...

I finally did the takeover manually and was able to mount the FS...

thanks again
Jonathan
Jonathan Caplette_1
Super Advisor

Re: vgchange -a n return device busy

closed