LVM and VxVM
cancel
Showing results for 
Search instead for 
Did you mean: 

vgcreate: Cannot open the control file "/dev/vg11/group"

SOLVED
Go to solution
Warren griggs
Frequent Advisor

vgcreate: Cannot open the control file "/dev/vg11/group"

Hi,

I am trying to add another couple of vg's but I am getting this error when I try...

"vgcreate: Cannot open the control file "/dev/vg11/group":
No Such Device"

I have increased the maxvgs kernel parameter to 16 (Currently have 10, trying to add the 11th) but this still has not helped.

Any help would be appreciated.

Thanks in advance,

Colin.
6 REPLIES
Vincenzo Restuccia
Honored Contributor

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

One can alter the value of maxvgs either in SAM or doing it by hand and
edit the /stand/system file and add something like :

maxvgs 16
Warren griggs
Frequent Advisor

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

Sorry Vincenzo you miss understood. I have already increased the maxvgs parameter but it has not helped.
Vincent Stedema
Esteemed Contributor

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

Hi,

Did you create the group file prior to issueing the vgcreate command?

# cd /dev/vg11
# mknod group c 64 0xnn0000

HTH.

Regards,

Vincent
John Palmer
Honored Contributor
Solution

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

Hi,

If you are manually creating the volume group then you have to follow the following procedure:-

1. Create the control directory mkdir /dev/vg11
2. Create the group file
mknod /dev/vg11/group c 64 0xnn0000
where nn is a unique hexadecimal number.
3. vgcreate

Have you created /dev/vg11 and the group file?

If so, have you created group with minor number 0x0b0000 (for vg11). If you used 0x110000 then that value is decimal 17 and is greater than maxvgs.

Regards,
John
MANOJ SRIVASTAVA
Honored Contributor

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

Hi Colin

It looks like you have only 11 or so vg's so reaching 16 nos is sort of 5 vg's away . Is the problems to do something with the /dev/vg11/group directory ? . Try creating a differnt group directory preferably with didfeernt major nos , or let SAM do the trick ?

Manoj Srivastava
Satish Y
Trusted Contributor

Re: vgcreate: Cannot open the control file "/dev/vg11/group"

Hi,

Actually you need to reboot the machine to make the change in kernal parameter maxvg effective. So try rebooting the machine if you have not done ... and then try adding the volume group.
Difference between good and the best is only a little effort