vmunix: file table is full

 
한국 휴렛팩커드
Regular Advisor

vmunix: file table is full

I am receiving the following messages. Can someone please advise me on how to alleviate this problem.

Thanks

Vmunix: file: table is full
8 REPLIES 8
Devender Khatana
Honored Contributor

Re: vmunix: file table is full

Hi,

You need to reconfigure your kernel with a few changes. Have a look at this thread

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=941443

HTH,
Devender
Impossible itself mentions "I m possible"
melvyn burnard
Honored Contributor

Re: vmunix: file table is full

you need to tune your kernel, in this case the parameter nfile needs to be increased.
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
saju_2
Respected Contributor

Re: vmunix: file table is full

Hi

This is another post from internet..

If you get (in syslog) vmunix: file: table is full, you need to tweak the nfile kernel parameter (number of files open at once).

That, however, keys off of nproc, which I changed instead. It defaults to `(20+8*MAXUSERS)'; changed it to `(20+16*MAXUSERS)'.

Regards
CS
Pedro Cirne
Esteemed Contributor

Re: vmunix: file table is full

Hi,

You must reconfigure your kernel parameter nfile, you may check the utilization level of the file table by using the sar command:

# sar -v 5 5

and look at he file-sz

Enjoy :)

Pedro
Florian Heigl (new acc)
Honored Contributor

Re: vmunix: file table is full

We also had this problem a few times until we raised a few parameters - nfile is what causes Your current error message.
yesterday I stood at the edge. Today I'm one step ahead.
Kent Ostby
Honored Contributor

Re: vmunix: file table is full

If this is something that has started happening recently, it could also be caused by a new or modified application that is opening too many files.


While the nfile changes above will certainly get rid of the condition, you might want to think about what else has changed on the system.

1) New applications
2) Changed applications
3) Additional usage

Best regards,

Oz
"Well, actually, she is a rocket scientist" -- Steve Martin in "Roxanne"

Re: vmunix: file table is full

I had the same problem.

I change nfile value from 5000 to 10000 today on hp-ux v11.11 and it seems to be fine right now.
Adisuria Wangsadinata_1
Honored Contributor

Re: vmunix: file table is full

Hi,

Check this url below (docID: HPUXKBRC00008909):

http://www1.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000080062403

From the document :
This error condition can be resolved by increasing the value of the NFILE
parameter. You may also wish to increase the MAXFILES parameter (per user file
limit). SAM will allow these changes to be made easily via the "Configurable
Parameters" section under "Kernel Configuration" area.

Hope this information can help you.

Cheers,
AW

PS : dont forget to assign the point
now working, next not working ... that's unix