LVM and VxVM

volume groups not activated after hostname change

 
Dave Chamberlin
Trusted Contributor

volume groups not activated after hostname change

Greetings, I am new with the EVA4400. I have data on the EVA, which was fine until I changed the hostname and rebooted. After this I can see the disks presented to the host, and all show claimed. The EVA host entry was updated to match new hostname (IP was not changed). How do I reactivate the vgs?
7 REPLIES 7
James R. Ferguson
Acclaimed Contributor

Re: volume groups not activated after hostname change

Hi Dave:

# vgchange -a y /dev/vgXX

Regards!

...JRF...
Dave Chamberlin
Trusted Contributor

Re: volume groups not activated after hostname change

Thanks - Why did they not activate automatically?
James R. Ferguson
Acclaimed Contributor

Re: volume groups not activated after hostname change

Hi (again) Dave:

> Why did they not activate automatically?

I assume that you had performed a 'vgimport'. If so, afterwards you need to activate the volume groups.

Regards!

...JRF...
Dave Chamberlin
Trusted Contributor

Re: volume groups not activated after hostname change

Hi James

I intially did a vgimport, vgchange , mounted the file systems etc. Will I have to reactivate the volume groups after each reboot? I don't do this for any other server...
James R. Ferguson
Acclaimed Contributor

Re: volume groups not activated after hostname change

Hi Dave:

At startup, '/sbin/lvmrc' runs looking at the variables you have set in '/etc/lvmrc'. Unless this is a MC/ServiceGuard environment, you generally want to activate all volume groups and thus you would set:

AUTO_VG_ACTIVATE=1

Regards!

...JRF...
Joachim Noffke
Occasional Advisor

Re: volume groups not activated after hostname change

Is it possible that you changed the volume group name while vgimport-ing it? If so, this could explain why the automatic VG activation no longer works. In this case do the following:

If your /etc/lvmrc has AUTO_VG_ACTIVATE set to 0, please check the "custom_vg_activation()" function further down in the same file. There should be a "vgchange -a y" command for your volume group. Change that line to reflect the new name of your VG.
Dave Chamberlin
Trusted Contributor

Re: volume groups not activated after hostname change

The AUTO_VG_ACTIVATE flag is set to 1 in the /etc/lvmrc file. I did not change volume group names when activating etc.