LVM and VxVM

vxdmpadm does not persist across reboots

 
Emil Velez
Honored Contributor

vxdmpadm does not persist across reboots

I need to disable vxvm from accessing some disks. I know I can do this with vxdiskadmin option (17 and 2) but I would like to do it in a script for multiple paths.

I have tried


vxdmpadm disable path=c5t0d3
vxdmpadm disable path=c7t0d3
vxdmpadm disable path=c9t0d3
vxdmpadm -f disable path=c11t0d3

unfortunately this does not persist across reboots although when I look at vxdiskadm it seems to call vxdmpadm

Thanks for any suggestions and points will be provided.

3 REPLIES 3
Sameer_Nirmal
Honored Contributor

Re: vxdmpadm does not persist across reboots

The command will disable the path only until the next system reboot. Because with the system reboot, the DMP restore daemon ( restored ) will re-enable the path. So disabling this daemon is required to avoid the behavior.

One of the scenario is described here.

http://seer.support.veritas.com/docs/254694.htm
Emil Velez
Honored Contributor

Re: vxdmpadm does not persist across reboots

I got a partial reply from the response center that solves the issue.


1. Create a new file /etc/vx/disks.exclude 2. Add cXtYdZ entries into /etc/vx/disks.exclude for each device path you want to exclude.
For example, if the HP-UX host has 4 available paths to a CLARiiON device c1t0d1, c2t0d1, c5t0d1, c6t0d; then add a new line entry into disks.exclude for each of the 3 duplicate paths c2t0d1, c5t0d1, c6t0d.
For example:
c2t0d1
c5t0d1
c6t0d1

3. Run to reinitialize
# vxconfigd -k -m enable -x exclude_enable 4. Edit the file/sbin/init.d/vxvm-startup to change the line "vxconfigd -k -m" to # vxconfigd -k -m enable -x exclude_enable

Note: the option -x exclude_enable is a undocumented option that can be of help to exclude probing devices on early daemon startup.



Another option was

I made a test with this:

For example, if I would like to see the "Excluded paths from VxVM"
You can create a file with the following contents:
vxdiskadm <<%
17
y
2
list
q
q
q
%

Or put the options list to be selected in a file and use:
# vxdiskadm < report_excluded_paths.txt >/tmp/vxdiskadm.log 2>&1


Emil Velez
Honored Contributor

Re: vxdmpadm does not persist across reboots

thanks i hope this helps others