BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

CPAM and perl modules not installed on hp-ux

SOLVED
Go to Solution
Regular Advisor

CPAM and perl modules not installed on hp-ux

I want to  installe mozilla and apache but when i was installing perl related and some error messages generated by server HP-UX

Checking for               CGI.pm (v3.51)     ok: found v3.55
Checking for           Digest-SHA (any)       not found
Checking for             TimeDate (v2.21)     not found
Checking for             DateTime (v0.28)     not found
Checking for    DateTime-TimeZone (v0.71)     not found
Checking for                  DBI (v1.41)     ok: found v1.601
Checking for     Template-Toolkit (v2.22)     not found
Checking for           Email-Send (v2.00)     not found
Checking for           Email-MIME (v1.904)    not found
Checking for                  URI (any)       ok: found v1.35
Checking for       List-MoreUtils (v0.22)     not found

Checking available perl DBD modules...
Checking for               DBD-Pg (v1.45)     not found
Checking for            DBD-mysql (v4.00)     not found
Checking for           DBD-Oracle (v1.19)     not found

The following Perl modules are optional:
Checking for                   GD (v1.20)     not found
Checking for                Chart (v2.1)      not found
Checking for          Template-GD (any)       not found
Checking for           GDTextUtil (any)       not found
Checking for              GDGraph (any)       not found
Checking for           MIME-tools (v5.406)    not found
Checking for          libwww-perl (any)       ok: found v2.036
Checking for             XML-Twig (any)       not found
Checking for          PatchReader (v0.9.4)    not found
Checking for            perl-ldap (any)       ok: found v0.34
Checking for          Authen-SASL (any)       not found
Checking for           RadiusPerl (any)       not found
Checking for            SOAP-Lite (v0.712)    found v0.55
Checking for             JSON-RPC (any)       not found
Checking for              JSON-XS (v2.0)      not found
Checking for           Test-Taint (any)       not found
Checking for          HTML-Parser (v3.40)     ok: found v3.56
Checking for        HTML-Scrubber (any)       not found
Checking for Email-MIME-Attachment-Stripper (any)       not found
Checking for          Email-Reply (any)       not found
Checking for          TheSchwartz (any)       not found
Checking for       Daemon-Generic (any)       not found
Checking for             mod_perl (v1.999022) not found
Checking for     Apache-SizeLimit (v0.93)     not found
Checking for   Math-Random-Secure (v0.05)     not found

 

(This modules also download,but when i installing this module only one module installed.and another modules generated

error messages)

One module error message during installation:-

 

uatdata1 /tmp/CPAM-PERL-MODULE#
uatdata1 /tmp/CPAM-PERL-MODULE#chmod 777  Test-Taint-1.04
uatdata1 /tmp/CPAM-PERL-MODULE#ls
Authen-Radius-0.20                           Email-Send-2.198                             PatchReader-0.9.6.tar.gz
Authen-SASL-2.15                             Email-Send-2.198.tar.gz                      RadiusPerl-0.20.tar.gz
Authen-SASL-2.15.tar.gz                      GD-2.46                                      Template-GD-2.66
DBD-Oracle-1.34                              GD-2.46.tar.gz                               Template-GD-2.66.tar.gz
DBD-Oracle-1.34.tar.gz                       GDGraph-1.44                                 Template-Plugin-TimeDate-1.02
DBD-Pg-2.18.1                                GDGraph-1.44.tar.gz                          Template-Plugin-TimeDate-1.02.tar.gz
DBD-Pg-2.18.1.tar.gz                         GDTextUtil-0.86                              Template-Toolkit-Simple-0.16
DBD-mysql-4.020                              GDTextUtil-0.86.tar.gz                       Template-Toolkit-Simple-0.16.tar.gz
DBD-mysql-4.020.tar.gz                       HTML-Scrubber-0.09                           Test-Taint-1.04
Daemon-Generic-0.81                          HTML-Scrubber-0.09.tar.gz                    Test-Taint-1.04.tar.gz
Daemon-Generic-0.81.tar.gz                   JSON-RPC-1.00                                TheSchwartz-1.10
DateTime-0.70                                JSON-RPC-1.00.tar.gz                         TheSchwartz-1.10.tar.gz
DateTime-0.70.tar.gz                         JSON-XS-2.32                                 XML-Twig-3.39
DateTime-TimeZone-1.42                       JSON-XS-2.32.tar.gz                          XML-Twig-3.39.tar.gz
DateTime-TimeZone-1.42.tar.gz                List-MoreUtils-0.33                          chart-246
Digest-SHA-5.63                              List-MoreUtils-0.33.tar.gz                   chart-246.tar.gz
Digest-SHA-5.63.tar.gz                       MIME-tools-5.411                             libwww-perl-6.03
Email-MIME-1.910                             MIME-tools-5.411.tar.gz                      libwww-perl-6.03.tar.gz
Email-MIME-1.910.tar.gz                      MIME-tools-5.502                             mod_perl-1.31
Email-MIME-Attachment-Stripper-1.316         MIME-tools-5.502.tar.gz                      mod_perl-1.31.tar.gz
Email-MIME-Attachment-Stripper-1.316.tar.gz  Math-Random-Secure-0.06                      mod_perl-2.0.5
Email-Reply-1.202                            Math-Random-Secure-0.06.tar.gz               mod_perl-2.0.5.tar.gz
Email-Reply-1.202.tar.gz                     PatchReader-0.9.6
uatdata1 /tmp/CPAM-PERL-MODULE#cd  Test-Taint-1.04
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#ls
Changes      MANIFEST     META.yml     Makefile.PL  Taint.pm     Taint.xs     ppport.h     t
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#perl Makefile.PL
Set up gcc environment - 4.2.1
Checking if your kit is complete...
Looks good
Writing Makefile for Test::Taint
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#make
cp Taint.pm blib/lib/Test/Taint.pm
        /usr/bin/perl /opt/perl_32/lib/5.8.8/ExtUtils/xsubpp  -typemap /opt/perl_32/lib/5.8.8/ExtUtils/typemap  Taint.xs > Taint.xsc && mv Taint.xsc Taint.c
Please specify prototyping behavior for Taint.xs (see perlxs manual)
        gcc -c    -D_POSIX_C_SOURCE=199506L -D_REENTRANT -D_HPUX_SOURCE +DSitanium2 -fPIC -DUSE_SITECUSTOMIZE -DNO_HASH_SEED -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fno-strict-aliasing -pipe     -DVERSION=\"1.04\"  -DXS_VERSION=\"1.04\" -fPIC "-I/opt/perl_32/lib/5.8.8/IA64.ARCHREV_0-thread-multi/CORE"   Taint.c
gcc: +DSitanium2: No such file or directory
*** Error exit code 1

Stop.
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#make test
Running Mkbootstrap for Test::Taint ()
        chmod 644 Taint.bs
        rm -f blib/arch/auto/Test/Taint/Taint.so
        gcc  -shared -static-libgcc -fPIC -L/usr/lib/hpux32 Taint.o  -o blib/arch/auto/Test/Taint/Taint.so      \
                \

        chmod 755 blib/arch/auto/Test/Taint/Taint.so
         cp Taint.bs blib/arch/auto/Test/Taint/Taint.bs
        chmod 644 blib/arch/auto/Test/Taint/Taint.bs
        PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00.load..............# Testing Test::Taint 1.04
t/00.load..............ok
t/no-dash-T............ok
t/pod-coverage.........skipped
        all skipped: Test::Pod::Coverage 0.08 required for testing POD coverage
t/pod..................skipped
        all skipped: Test::Pod 1.00 required for testing POD
t/taint................ok
t/taint_deeply.........ok
t/tainted..............ok
t/tainted_ok...........ok
t/tainted_ok_deeply....ok
All tests successful, 2 tests skipped.
Files=9, Tests=141,  1 wallclock secs ( 0.63 cusr +  0.13 csys =  0.76 CPU)
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#
uatdata1 /tmp/CPAM-PERL-MODULE/Test-Taint-1.04#cd /
uatdata1 /#perl --versiob
Unrecognized switch: --versiob  (-h will show valid options).

 

 

How can installed that module properly(my perl version is5..8.8.8)

OS=HP-UX 11i

 

PLease help me..........................................................

 

 

Thanks
aamir uddin
1 REPLY
Highlighted
Acclaimed Contributor

Re: CPAN and perl modules not installed on HP-UX

[ Edited ]

>gcc: +DSitanium2: No such file or directory

 

This is a cc(1) option, remove it.

 

>OS=HP-UX 11i

 

This is not helpful.  What does "uname -a" return?

 

>/#perl --versiob
Unrecognized switch: --versiob  (-h will show valid options).

 

You made a typo.