Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

Compiling on HPUX 11.31 Itanium with ldap library

SOLVED
Go to solution
Highlighted
joeyu1201
Occasional Advisor

Compiling on HPUX 11.31 Itanium with ldap library

I am compiling 32-bit program with ldap libray and error occur "ld: Mismatched ABI (not an ELF file) for -lldap50, found /iseprod/ivrshrt/.lib/libldap50.sl".

I have checked the library libldap50.sl is 32-bit.
$ file /iseprod/ivrshrt/.lib/libldap50.sl
/iseprod/ivrshrt/.lib/libldap50.sl: PA-RISC1.1 shared library -not stripped

Is there any other reason cause the error?
3 REPLIES
Dennis Handly
Acclaimed Contributor
Solution

Re: Compiling on HPUX 11.31 Itanium with ldap library

Besides having to match on bitness, you have to match on architecture.
Your shlib is PA, you need an Integrity version.
joeyu1201
Occasional Advisor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.
joeyu1201
Occasional Advisor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.