Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

Hiding symbols at link time on hp-ux 10.20

SOLVED
Go to solution
DS_5
Occasional Contributor

Hiding symbols at link time on hp-ux 10.20


Hi,
I am trying to build libraries in 10.20 with the "-h" link option.

I actually pass a file containing all the symbols to hide via +Wl,-c...

I get errors like:
/usr/c/bin/ld: can't hide symbol...
for all the symbols I want to hide.

Do you know why ?
How can I fix this ?

Thank you,
Amedee
3 REPLIES
Highlighted
ranganath ramachandra
Esteemed Contributor
Solution

Re: Hiding symbols at link time on hp-ux 10.20

please check whether the symbols are resolved within the module (executable or shared library) that you are trying to build. if they are not, they are unsats and the linker will not hide them.
DS_5
Occasional Contributor

Re: Hiding symbols at link time on hp-ux 10.20

Hi Ranganath,

Thanks for you reply.

You were right, the symbols were not concerning the module to be built.
This is not a problem anymore.

Thanks a lot,
Amedee
DS_5
Occasional Contributor

Re: Hiding symbols at link time on hp-ux 10.20

closing thread.