Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

JRE 1.4.2_03 compatibility with SDK 1.4.2_04

 
Antonio Cardoso_1
Trusted Contributor

JRE 1.4.2_03 compatibility with SDK 1.4.2_04

Hi all,
could anyone tell me if there is any risk in running on a HP-UX JRE 1.4.2_03 some applications compiled with a SDK 1.4.2_04 ?

that is, is there any incompatible change between SDK 1.4.2_03 and SDK 1.4.2_04 that could cause some trouble?

thank's
1 REPLY 1
Steven E. Protter
Exalted Contributor

Re: JRE 1.4.2_03 compatibility with SDK 1.4.2_04

There is a risk. I would not run a legacy application that a business depends on in that mode.

The new release includes upgrade, bug fixes and changes in behavior that can effect the way that java works, interacts with the server and interacts with the users.

Best practice would be to plan an upgrade that gets the same version of java everwhere.

Among the various pc's in my web hosting businesses internal network, I'm not that stringent, because there is no difference on a day to day basis. We simply don't take these kind of chances when the Enterprise depends on it.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com