Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

Java dependency in OpenVMS 8.3

Go to Solution
Valued Contributor [Founder]

Java dependency in OpenVMS 8.3

We are in the process of upgrading to OpenVMS 8.3 from 7.3-2 (for Alpha). Our Dept. of Defense security guys go berserk over Java because they cannot abide by "mobile code" platforms. I will avoid casting aspersions regarding paranoia at this time, because it does no good. Water off a duck's back and all that.

So the DoD security gurus have essentially told me that the version of Java that we had on VMS 7.3-2 (which was Java 1.2-23) is no longer allowed on our systems. MUST be removed completely.

We are NOT web-enabled, either way you might considered it. I.e. we don't run the Web Server and we do not run a public version of DECwindows, so nobody has an X screen or any VMS-based browser. This also means no WEBES and no other obvious things that could be at least intermittantly and/or temporarily web-enabled on the system. Our system is more batch-oriented and character-cell-graphic menu driven than anything else.

So my question is, if we are not running any of our applications code under Java and we are not running Web-enabled, in or out, is there any part of the OpenVMS O/S that still needs Java? I just said I know of nothing obvious, but what bothers me is the less-than-obvious cases that crop up sometimes.

I want to remove Java but before I do, I thought it might be wise to know if I'm going to trip over a "gotcha" somewhere under obscure OpenVMS 8.3 operations.

By the way, if I can get away with it, I will not install the newer version of Java (I think 1.5-something, JDK 3.0) from the e-Business kit. I want to get to a system that has no Java at all if that is possible.
Sr. Systems Janitor
Honored Contributor [Founder]

Re: Java dependency in OpenVMS 8.3

I think you covered your bases.
Core OpenVMS does not need Java.
Rename and reboot to verify?