Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in running scripts

kirupakaran
Occasional Visitor

Problem in running scripts

Hi all,

Please someone tell me how to run script using nohup option in HP-Unix..

I am unable to use @ symbol in HP-unix ...

i usually run scritps in solaris as below..
eg:nohup sqlplus system/oracle @script.sql &

can anyone plese tell me how to run the same in HP-unix..

 

P.S. This thread has been moved from  Disk to HP-UX > languages. -HP Forum Moderator

6 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Problem in running scripts

What happens when you use "@"? This isn't a special char except it may be the line kill char. See "stty -a". Fix by:
$ stty kill ^u

Do you intend "@" to be anything other than a data char or part of a filename of command?
kirupakaran
Occasional Visitor

Re: Problem in running scripts

Hi Handley,

Thanks for your response..

The problem is...

see we have an sql script in one of my partion..

i want to run the script..

what we usually do for another client using solaris..we will run the script by nohup option..

nohup sqlplus system/oralce @script.sql &

@ not a filename we use to call script that we have stored in current partion.

so please suggest me how to rubn scripts in HP-unix..


Dennis Handly
Acclaimed Contributor

Re: Problem in running scripts

>we will run the script by nohup option..
nohup sqlplus system/oracle @script.sql &

You are running the script "sqlplus" with the
arguments: system/oracle and @script.sql. Then putting it in the background with the output sent to nohup.out

>@ not a filename we use to call script that we have stored in current partion.

"@" is just a character and isn't anything special to a real shell.

>so please suggest me how to run scripts in HP-UX

sqlplus is your script. Unless your question is about sqlplus scripts?? (Which has nothing to do with nohup.)
Dennis Handly
Acclaimed Contributor

Re: Problem in running scripts

>"@" is just a character and isn't anything special to a real shell.

Actually in a real shell, "@" is used as a parm, $@ and for file name generation.

The scummy C shell uses it for assignment.

None of these appears to be what you are trying to do.
Sajeev_1
Advisor

Re: Problem in running scripts

use '\' before @...
nohup sqlplus system/oracle \@script.sql &

hope this helps..

Sajeev
Highlighted
Hpuxuser01
Occasional Visitor

Re: Problem in running scripts

it works...your answer is still helpful and valuable. Thanks