Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

make not recognising 64 bit

wayne_104
Regular Advisor

make not recognising 64 bit

I have installed the GNU_C_C++ 4.4.3

compiler.

I am now running the ./configure for unixodbc

but it does not recognise that the system is 64 bit.

when - use CC=-m64 it comes up with an error.

checking for export-gcc... -m64
checking for C compiler default output file name...
configure: error: in `/home/software/UNIXODBC/unixODBC-2.3.0':
configure: error: C compiler cannot create executables
See `config.log' for more details.


why is this???
4 REPLIES
Patrick Wallek
Honored Contributor

Re: make not recognising 64 bit

>>See `config.log' for more details.

What does the config.log show?
Steven Schweda
Honored Contributor

Re: make not recognising 64 bit

> make not recognising 64 bit

It's not a "make" problem.

> when - use CC=-m64 it comes up with an
> error.

As usual, showing the actual command with its
actual output might be more helpful than a
vague description or interpretation.

"CC=-m64" seems unlikely to work, because
"-m64" is probably not a valid compiler
command. Perhaps something like
CC='gcc -m64'
?

But, depending on what else is in your "make"
file, changing "CC" may or may not do all
that's needed to get the right 64-bit options
where they're needed.
wayne_104
Regular Advisor

Re: make not recognising 64 bit

./configure export CC='gcc -m64'
configure: WARNING: you should use --build, --host, --target
checking for a BSD-compatible install... libltdl/config/install-sh -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... libltdl/config/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) awk
checking for bison... no
checking for byacc... no
checking for style of include used by make... GNU
checking for export-gcc... gcc -m64
checking for C compiler default output file name...
configure: error: in `/home/software/UNIXODBC/unixODBC-2.3.0':
configure: error: C compiler cannot create executables
See `config.log' for more details.
Highlighted
wayne_104
Regular Advisor

Re: make not recognising 64 bit

-milp32
-mlp64

Generate code for a 32-bit or 64-bit environment. The 32-bit environment sets
int, long and pointer to 32 bits. The 64-bit environment sets int to 32 bits and
long and pointer to 64 bits. These are HP-UX specific flags.