Languages and Scripting
cancel
Showing results for 
Search instead for 
Did you mean: 

samba 3.3.7 or 3.4 on hpux 11i v1 ( 11.11 )

 
Highlighted
klb
Valued Contributor

samba 3.3.7 or 3.4 on hpux 11i v1 ( 11.11 )

 

Since CIFS package is not available for hpux 11.11, I'm attempting to compile the source of these versions on my platform.  However I keep getting hung up running configure with the following error:

 

checking size of char... 0

checking size of short... 0

checking size of long... 0

checking size of long long...

configure: error: in `.../src/samba/samba-3.3.16/source':configure: error: cannot compute sizeof (long long)

See `config.log' for more details

 

In config.log I find only this:

 

configure:5868: checking size of long long

configure:5873: cc -o conftest  -c99 -AC99 -Dpread=pread64 -Dpwrite=pwrite64   conftest.c  >&5

cc: warning 422: Unknown option "9" ignored.

cc: warning 422: Unknown option "9" ignored.

cc: error 1412: Option A usage: -A level where level may be a or c.configure:5873: $? = 0

configure:5873: ./conftest

./configure[20]: ./conftest: Execute permission denied.configure:5873: $? = 126

configure: program exited with status 126

 

Note that I am running the ANSI/C compiler ( purchased compiler for hpux 11.11 ).

 

The latest binary distribution of Samba that I have found is 3.0.X, which doesn't support windows 7 clients ( 3.3.7 is the earliest version with windows 7 support )

 

Any ideas how I can get around this error?  Any ideas where I might be able to find a Samba binary distribution for hpux 11.11 that is at or beyond Samba 3.3.7?

 

I have attached the config.log for your reference.

 

Thanks,

 

-klb

 

 

1 REPLY 1
Highlighted
Dennis Handly
Acclaimed Contributor

Re: samba 3.3.7 or 3.4 on HP-UX 11.11

>However I keep getting hung up running configure with the following error:

configure:5873: cc -o conftest  -c99 -AC99

cc: error 1412: Option A usage: -A level where level may be a or c.configure:5873: $? = 0

 

This is your problem.  You need to remove that -c99 from the configure tests and perhaps more will work.