LoadRunner Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

"nca_connect_server: cannot communicate with host"

Occasional Collector

"nca_connect_server: cannot communicate with host"

I'm working with (web(Http/Html)& Oracle NCA) multi protocol using Loadrunner 11.5 to record the script in Oracle R12 forms. When I tried to replay the script I got the error "nca_connect_server: cannot communicate with host xxxxx on port 8004". Could you please let me know how to resolve the issue.


Re: "nca_connect_server: cannot communicate with host"



Make sure you are using the correct proxy settings in the Run Time Settings > Internet Protocol > Proxy.



Occasional Collector

Re: "nca_connect_server: cannot communicate with host"



I tried to replay the script using no proxy. But still the error persists.


Re: "nca_connect_server: cannot communicate with host"

The script is missing a lservlet step;therefore during replay the script is failing to establish connection,hardcoded jsessionid is being used.


Try doing this:


1-Add "application/octet-stream" content type as non-resource in:Recording Options > HTTP Properties > Advanced > Non-Resources.

2-Regenerate the script in URL mode

3-Correlate the jsessionid value





HPE Expert

Re: "nca_connect_server: cannot communicate with host"

There may be several possible causes for this, the most obvious is the proxy, make sure to select "use browser settings", if this give the same error, then check correlations, usually you need to correlate the jsessionsid and the icxticket.

try that and let us know

Frequent Advisor

Re: "nca_connect_server: cannot communicate with host"



Mostly this issue should be due to the NCAJSession id not being correlated.

Do you have a web_reg_save_param step before the connect statement in the script?

The auto correlation feature should normally have correlated this value.


Try re-recording with the auto correlation enabled.

If this works, you may start getting a new type of error :)

come back after you get over this hurdle for now .