LoadRunner and Performance Center
Showing results for 
Search instead for 
Do you mean 

5 tips to solve the most common problems seen in Web recording

Anonymous_User1 ‎01-30-2014 06:20 AM - edited ‎09-22-2015 01:42 PM

(This post was written by Gennady Gorenshtein, from the LoadRunner R&D Team)


Recording a LoadRunner test script in Virtual User Generator (VuGen) is usually very simple - click the record button, do whatever needs to be done in the browser, and click the ‘Stop Recording’ button.  But occasionally, the results might not be what you expected.


Here are the five most common problems seen when recording a test using the Web (HTTP/HTML) protocol, and how to resolve them. 


Problem 1: No events are being recorded

Here are the most common reasons why no events are showing in the script:


The events counter keeps increasing, while the generated script is empty

This may be because VuGen’s recording mechanism fails to identify HTTP data. To fix it, ensure that your application indeed uses HTTP Web traffic. If the application uses SSL connections, make sure you choose the correct SSL version (SSL 2, SSL 3, TLS) through the Port Mapping dialog, available by clicking the ‘Options…’ button on the Record > Recording Options… dialog:


The Advanced Port Mapping Settings dialog opens when you click ‘Options…’:


The events counter shows less than five events, while the application keeps getting data from the server

In this case, VuGen’s recording mechanism fails to capture any network activity at all. Ensure that your application really does provide some network traffic, ie. it sends and receives data through the IP network. If an antivirus program is running, turn it off during recording. Check the recording log for any clues about the recording failure. Messages such as “connection failure” or “connection not trapped” can be a sign of the wrongly configured Port Mapping settings.

In addition, if you are recording on a Chrome or Firefox browser, make sure that all the instances of the browser are closed prior to the recording.


Problem 2: Specific events are not recorded

This problem could be caused by the event being dropped as “uninteresting”. By default, VuGen’s Web (HTTP/HTML) protocol records client requests that return an HTTP response status of 2xx or 302, and discards all other requests. If a missing request returns a response that was discarded, such as 301, you can make a modification to the registry to instruct VuGen to generate a command for it:


  • Locate the following registry key:
    • [HKEY_CURRENT_USER\Software\Mercury Interactive\Networking\Multi Settings\QTWeb\Recording]
  • Add the following string value to it:
    • "GenerateApiFuncForCustomHttpStatus"="301"

Problem 3: The recorded application becomes unresponsive during the recording

This could be caused by VuGen’s recording mechanism not being able to connect to the application’s server. Network connection errors can be seen in the Recording Log:


[Net An. Warning  (1068:197c)] Request Connection: Remote Server @ - 5222 (Service=) Failed attempt #1. Unable to connect to remote server: rc = -1 , le = 10060)
[Net An. Warning  (1068:197c)] Request Connection: Remote Server @ - 5222 (Service=) Failed attempt #2. Unable to connect to remote server: rc = -1 , le = 10060)


Note: the Recording log is in the ‘Output’ pane.  Make sure ‘Recording’ is selected in the combo-box on the left:


In order to fix this problem, the Port mapping for the specific IP and port should be added to the Port Mapping dialog (under the Record > Recording Options… menu), and the entry should be unchecked. That will ensure that the above IP and port are not recorded – that application simply connects to them without any LoadRunner involvement. For the messages above the correct setting would be:


This workaround can be done in case the communication to is not important for the business process and can be omitted. If that’s not the case, the same entry should still be added, but left as checked. That will ensure correct traffic capture to this address.


Problem 4: During the recording the recorded application shows an error message about the wrong server certificate

The problem is caused by the inability of the client side to verify the validity of the server certificate. In order to fix this problem, the LoadRunner Certificate Authority (CA) file should be added to the machine’s “Trusted Root Certificate Authorities” certificate store (in case of a Java client application, LoadRunner’s CA should be added to Java’s trusted CA list using the keytool). This file is supplied with LoadRunner, and is called wplusCAOnly_Expiration_2022.crt. It’s located in the <LR_folder\bin\certs> folder.


To add it to the store, double-click on the file to open the certificate:


Then click ‘Install Certificate…’ to open the Certificate Import Wizard’:


Make sure you check ‘Place all certificates in the following store’ and select ‘Trusted Root Certification Authorities’.  When the wizard is completed, you should be able to record the application.


Problem 5: The browser crashes during recording when using the Ajax Click and Script protocol

This can happen when some of the Ajax controls inside the application are not recognized by VuGen. In order to fix it:


  • Go to the  <LR_folder\dat\protocols> folder and open the WebAjax.lrp file
  • Comment out the following: DllGetClassObject:jscript.dll=DllGetClassObjectHook:ajax_hooks.dll (simply put a semi-colon (‘;’) in front of the line)

You should now be able to record the application.


You can download LoadRunner here.



We hope you found this article useful.  Let us know by leaving a comment in the box below.



Thanks to Gennady for providing this article!

About the Author


ronald sercely
on ‎02-04-2014 06:34 AM

Excellent article. Thank you.


I have had a case open with support for over 6 months.

on machine 1 - 11.52 patch 1 - web Click and Script recording - event count increases, recording log looks fine, but zero steps in the script.


On a second machine, IDENTICAL corporate image, so same OS, anti-viral, etc., have 11.0 installed - script records fine, and the steps exists in the script!


I am only posting this, because this is a different issue than what you have posted.

on ‎02-04-2014 10:04 AM ‎02-06-2014 12:36 PM Anonymous_User1

Hi Ronald,


Thank you for your comment.

The problem you are experiencing can be caused by 2 factors:

1) the C&S layer is not working on 11.52 machine.

2) if you are using the SSL, the script on 11.52 is recorded in the "Direct" mode.


You can check whether 1) is relevent if you will regenerate that blank 11.52 script in HTML mode (Regenerate options\General\Recording). If you will see the Web script, that would mean that the C&S layer is not working and the only option is to resolve to the regular Web recording.


In case of 2), please see the Port Mapping dialog – one dialog that does it all blog.



Somesh Singh
on ‎04-02-2014 03:02 AM

Great Article ....gives insight into the rootcause of problem.


Thanks for sharing. Solves lot of problem.


But to add to problem 1 sometimes selecting capture level as winI Net also solves the problem.


on ‎04-06-2014 08:20 AM


thanks for the info


can you clearly explain the step 5












on ‎11-21-2014 05:06 PM

I am having issue with recording script by using web-http/html protocol on Chrome. when try to start recording page becomes unresponsive..

on ‎12-17-2014 08:10 AM



This issue is fixed in LR 12.02 version.

Please try to record your script with it.

on ‎01-28-2015 01:08 PM



I have a delphi application but when I record no script is generated and it doesnt work, the application is opened but the script is not generated. Does Loadrunner work with Delphi apps? if  so which protocols to use ? I tried all protocols but in vain. please advise as its frustrating



thanks in advance

on ‎01-29-2015 09:03 AM



LR doesn't care much about the way the application is written.

The only meaningful thing is a protocol between client and server. 

What your application is trying to achieve and how?

If it's using database protocol (as most Delphi cases), you have to choose the appropriate LR protocol (Oracle, ODBC, etc).

on ‎01-29-2015 02:02 PM



Its a standalone desktop application. once opened the user can connect and send xml messages to another remote application


All I try to do is record pressing the button for connection and then pressing the send message for xml, But no script is generated. They are just buttons withon the application. any ideas?

Kamala Kanta Rath
on ‎04-05-2015 12:12 PM

Excellent Article. It really helps .

Deepak Varshney
on ‎06-17-2015 10:34 PM

Excellent article for people who are stuck with weird problems!!!

I am also looking forward to similar help page for recording Ajax Applications as there are mutiple challenges in

recording Ajax based web layers. 

on ‎06-22-2015 11:48 AM

Hello all,


With the time we have found another cause for recording failures.

Apparently, the recording can crash or severely malfunction in the presence of antivirus code change prevention mechanisms. 

In particular, McAfee Host Instrusion Prevention (HIP) is one of these mechanisms.

The only workaround possible is to uninstall such programs.

After the uninstall procedure, the LR recording should be started again (no computer's reset is required).


on ‎06-23-2015 12:16 PM



I am using Loadrunner 9.10 . When I clicked on record to record hp web tour website browser getting crashed same happens with win32 application.

Kindly suggest solution.



on ‎07-02-2015 06:24 AM

Hi Technosnoop,


LoadRunner 9.10 is no longer supported.  I suggest you upgrade to LoadRunner 12, the current version.  If you still have problems recording, then you should open a support ticket so we can investigate the issue.



on ‎07-29-2015 11:49 AM

Hi all,


Here is another tip regarding LR recording.

This time it considers Java application recording with SSL.


You need to install LR CA certificate inside your Java certificate store.

Here are a few steps for this:

  • Record your application with Vugen and see in the recording log path to java.exe. That will be the path to your Java installation. (say C:\Program Files (x86)\Java\jre6\bin)
  • Go to your Java installation and find there keystore file. It should be something like C:\Program Files (x86)\Java\jre6\lib\security (you can do a search for cacerts file)
  • Copy to C:\Program Files (x86)\Java\jre6\lib\security LR CA certificate from C:\Program Files (x86)\HP\LoadRunner\bin\certs\wplusCAOnly_Expiration_2022.crt
  • Rename the file from 3) to wplus.crt
  • Open the command prompt, run cd  C:\Program Files (x86)\Java\jre6\lib\security
  • Run C:\Program Files (x86)\Java\jre6\bin\keytool –list –keystore cacerts (no quotes)
  • You should see the list of all installed certificates, prompted by password enquiry use “changeit” passphrase (no quotes)
  • Now run “C:\Program Files (x86)\Java\jre6\bin\keytool –import –file wplus.crt –keystore cacerts –alias HPCA” (no quotes), prompted by password enquiry use “changeit” passphrase (no quotes)
  • As LR CA certificate is installed, start recording again.
on ‎04-08-2016 05:44 PM


I am trying to record a script. The events and steps show up in Vugen proper. until login. But after login, when i click on some dashboard tabs, nothing generates in the script. However I see that recording events are captured.

I tried the following options -

1) Changed SSL / TLS version

2) Changed Capture level to Wininet and socket / wininet.

3) Tried on different machine.

4) Disabled any proxies.

None of the above helped. 

Upon investigating the recording logs, I observed these messages 

[Network Analyzer (318c:332c)] (Sid: 17) Client -> Server @ : 1188 bytes (SSL)(Service=HTTP)
[Web Request (318c:332c)] "GET /api/1.0/batches"
[Network Analyzer (318c:332c)] (Sid: 10) Client -> Server @ : 1214 bytes (SSL)(Service=HTTP)
[Network Analyzer (318c:3118)] Address lookup for Harsha-GTX-Ti =
[Network Analyzer (318c:332c)] (Sid: 17) Server -> Client : 962 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:3118)] Request Connection: Remote Server @ (Service=) (Sid= 24) PROXIED!
[Web Request (318c:332c)] "GET /api/1.0/errors?rowsPerPage=8&pageNumber=1"
[Network Analyzer (318c:332c)] (Sid: 17) Client -> Server @ : 1240 bytes (SSL)(Service=HTTP)
[Network Analyzer (318c:332c)] (Sid: 10) Server -> Client : 2321 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:332c)] (Sid: 17) Server -> Client : 962 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:1a68)] (Sid: 24) Negotiate Proxy -> Server SSL Handshake (ssl:TLSv1.1, ciphers:ECDHE-RSA-AES128-SHA)
[Network Analyzer (318c:1a68)] (Sid: 24) Negotiate Client -> Proxy SSL Handshake (ssl:TLSv1.2, ciphers:AES128-GCM-SHA256)

However in the script its blank. Please suggest.


on ‎05-04-2016 10:18 PM

I am new to Load Runner 12.5, i have installed, started the web tours server and then i logged in to the application. when i click on filghts option application displays internal server error, as follows :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Can any one help me to resolve this issue...

27 Feb - 2 March 2017
Barcelona | Fira Gran Via
Mobile World Congress 2017
Hewlett Packard Enterprise at Mobile World Congress 2017, Barcelona | Fira Gran Via Location: Hall 3, Booth 3E11
Read more
Each Month in 2017
Software Expert Days - 2017
Join us online to talk directly with our Software experts during online Expert Days. Find information here about past, current, and upcoming Expert Da...
Read more
View all