LoadRunner and Performance Center
Showing results for 
Search instead for 
Did you mean: 

Re: 5 tips to solve the most common problems seen in Web recording

Somesh Singh

Great Article ....gives insight into the rootcause of problem.


Thanks for sharing. Solves lot of problem.


But to add to problem 1 sometimes selecting capture level as winI Net also solves the problem.


0 Kudos
About the Author

Somesh Singh

ronald sercely

Excellent article. Thank you.


I have had a case open with support for over 6 months.

on machine 1 - 11.52 patch 1 - web Click and Script recording - event count increases, recording log looks fine, but zero steps in the script.


On a second machine, IDENTICAL corporate image, so same OS, anti-viral, etc., have 11.0 installed - script records fine, and the steps exists in the script!


I am only posting this, because this is a different issue than what you have posted.


Hi Ronald,


Thank you for your comment.

The problem you are experiencing can be caused by 2 factors:

1) the C&S layer is not working on 11.52 machine.

2) if you are using the SSL, the script on 11.52 is recorded in the "Direct" mode.


You can check whether 1) is relevent if you will regenerate that blank 11.52 script in HTML mode (Regenerate options\General\Recording). If you will see the Web script, that would mean that the C&S layer is not working and the only option is to resolve to the regular Web recording.


In case of 2), please see the Port Mapping dialog – one dialog that does it all blog.



Somesh Singh

Great Article ....gives insight into the rootcause of problem.


Thanks for sharing. Solves lot of problem.


But to add to problem 1 sometimes selecting capture level as winI Net also solves the problem.




thanks for the info


can you clearly explain the step 5













I am having issue with recording script by using web-http/html protocol on Chrome. when try to start recording page becomes unresponsive..




This issue is fixed in LR 12.02 version.

Please try to record your script with it.




I have a delphi application but when I record no script is generated and it doesnt work, the application is opened but the script is not generated. Does Loadrunner work with Delphi apps? if  so which protocols to use ? I tried all protocols but in vain. please advise as its frustrating



thanks in advance




LR doesn't care much about the way the application is written.

The only meaningful thing is a protocol between client and server. 

What your application is trying to achieve and how?

If it's using database protocol (as most Delphi cases), you have to choose the appropriate LR protocol (Oracle, ODBC, etc).




Its a standalone desktop application. once opened the user can connect and send xml messages to another remote application


All I try to do is record pressing the button for connection and then pressing the send message for xml, But no script is generated. They are just buttons withon the application. any ideas?

Kamala Kanta Rath

Excellent Article. It really helps .

Deepak Varshney

Excellent article for people who are stuck with weird problems!!!

I am also looking forward to similar help page for recording Ajax Applications as there are mutiple challenges in

recording Ajax based web layers. 


Hello all,


With the time we have found another cause for recording failures.

Apparently, the recording can crash or severely malfunction in the presence of antivirus code change prevention mechanisms. 

In particular, McAfee Host Instrusion Prevention (HIP) is one of these mechanisms.

The only workaround possible is to uninstall such programs.

After the uninstall procedure, the LR recording should be started again (no computer's reset is required).





I am using Loadrunner 9.10 . When I clicked on record to record hp web tour website browser getting crashed same happens with win32 application.

Kindly suggest solution.




Hi Technosnoop,


LoadRunner 9.10 is no longer supported.  I suggest you upgrade to LoadRunner 12, the current version.  If you still have problems recording, then you should open a support ticket so we can investigate the issue.




Hi all,


Here is another tip regarding LR recording.

This time it considers Java application recording with SSL.


You need to install LR CA certificate inside your Java certificate store.

Here are a few steps for this:

  • Record your application with Vugen and see in the recording log path to java.exe. That will be the path to your Java installation. (say C:\Program Files (x86)\Java\jre6\bin)
  • Go to your Java installation and find there keystore file. It should be something like C:\Program Files (x86)\Java\jre6\lib\security (you can do a search for cacerts file)
  • Copy to C:\Program Files (x86)\Java\jre6\lib\security LR CA certificate from C:\Program Files (x86)\HP\LoadRunner\bin\certs\wplusCAOnly_Expiration_2022.crt
  • Rename the file from 3) to wplus.crt
  • Open the command prompt, run cd  C:\Program Files (x86)\Java\jre6\lib\security
  • Run C:\Program Files (x86)\Java\jre6\bin\keytool –list –keystore cacerts (no quotes)
  • You should see the list of all installed certificates, prompted by password enquiry use “changeit” passphrase (no quotes)
  • Now run “C:\Program Files (x86)\Java\jre6\bin\keytool –import –file wplus.crt –keystore cacerts –alias HPCA” (no quotes), prompted by password enquiry use “changeit” passphrase (no quotes)
  • As LR CA certificate is installed, start recording again.


I am trying to record a script. The events and steps show up in Vugen proper. until login. But after login, when i click on some dashboard tabs, nothing generates in the script. However I see that recording events are captured.

I tried the following options -

1) Changed SSL / TLS version

2) Changed Capture level to Wininet and socket / wininet.

3) Tried on different machine.

4) Disabled any proxies.

None of the above helped. 

Upon investigating the recording logs, I observed these messages 

[Network Analyzer (318c:332c)] (Sid: 17) Client -> Server @ : 1188 bytes (SSL)(Service=HTTP)
[Web Request (318c:332c)] "GET /api/1.0/batches"
[Network Analyzer (318c:332c)] (Sid: 10) Client -> Server @ : 1214 bytes (SSL)(Service=HTTP)
[Network Analyzer (318c:3118)] Address lookup for Harsha-GTX-Ti =
[Network Analyzer (318c:332c)] (Sid: 17) Server -> Client : 962 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:3118)] Request Connection: Remote Server @ (Service=) (Sid= 24) PROXIED!
[Web Request (318c:332c)] "GET /api/1.0/errors?rowsPerPage=8&pageNumber=1"
[Network Analyzer (318c:332c)] (Sid: 17) Client -> Server @ : 1240 bytes (SSL)(Service=HTTP)
[Network Analyzer (318c:332c)] (Sid: 10) Server -> Client : 2321 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:332c)] (Sid: 17) Server -> Client : 962 bytes (SSL) (Service=HTTP)
[Network Analyzer (318c:1a68)] (Sid: 24) Negotiate Proxy -> Server SSL Handshake (ssl:TLSv1.1, ciphers:ECDHE-RSA-AES128-SHA)
[Network Analyzer (318c:1a68)] (Sid: 24) Negotiate Client -> Proxy SSL Handshake (ssl:TLSv1.2, ciphers:AES128-GCM-SHA256)

However in the script its blank. Please suggest.



I am new to Load Runner 12.5, i have installed, started the web tours server and then i logged in to the application. when i click on filghts option application displays internal server error, as follows :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Can any one help me to resolve this issue...

June 6 - 8, 2017
Las Vegas, Nevada
Discover 2017 Las Vegas
Join us for HPE Discover 2017 in Las Vegas. The event will be held at the Venetian | Palazzo from June 6-8, 2017.
Read more
Each Month in 2017
Software Expert Days - 2017
Join us online to talk directly with our Software experts during online Expert Days. Find information here about past, current, and upcoming Expert Da...
Read more
View all