M and MSM Series
cancel
Showing results for 
Search instead for 
Did you mean: 

5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

 
SOLVED
Go to solution
Highlighted
Valued Contributor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

Thanks, I got this too late Friday to try it, but I will first thing on Monday.

Highlighted
Established Member

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

Just for general knowledge the fix suggested by AnilGuptaAtHP works. Just did the change in a client's implementation and it fixed the Airplay issue.

 

 

Highlighted
Valued Contributor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

Yes, it seems to work for me, too. I marked this as "solved," but only because "temporary workaround was provided" is not an option. I very much appreciate the tip, and I do hope it is fixed properly very soon.

Thx

Highlighted
Occasional Visitor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

Hey guys, I found it interesting to find that others are having a situation so similar to mine. I am also running a 765zl with 460 WAPs on 5.7.0.3. We have apple tv's in our classrooms but mine were acting a little different. The ipads could see and mirror to the apple tv's so long as they were on the same WAP. If the ipad or apple tv decided to connect to a different WAP then the apple tv's airplay could no longer be seen. I tried some of the fixes in this post but nothing changed what could be seen on each WAP. My guess was that there was something blocking the broadcast/multicast traffic that the apple tv spits out but I have not found a fix yet. Anyone else have a similar issue?

Highlighted
Valued Contributor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

under controlled APs-> Configuration-> Multicast

Do you have "IGMP snooping helpers" enabled?

You may need to enable IGMP or "multicast filtering" on all switches in the mix, too. 

 

 

Highlighted
Regular Advisor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

Agree with tschaps on that.

 

I also make sure that my wireless VLANs have "ip igmp" enabled in the switch configuration too. 

 

 

Jesse R
Source One Technology, Inc.
HP Partner


MSM 5.7.x deployment guide:

Highlighted
Occasional Visitor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

I am still having the same issue of having airplay only work if the ipad and appletv are connected to the same exact WAP. IGMP snooping is enabled and I enabled IGMP on all my switches. Any other good ideas? Thanks for looking!

 

Edit: I also tried tweaking the QoS settings to no avail

Highlighted
Valued Contributor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

I would set up a special VSC for each radio on the 460's, such as "AirplayTest5G" and "AirplayTest2.4G" and restrict each one to one of the radios but both on the same vlan. You should also create a separate Controlled AP Group with those VSCs so you only need to sync one radio, and then you know that if you connect two devices to the AP, one to each radio,  you're only dealing with one AP. You can then experiment with a variety of settings, but mainly, you can ascertain whether the mirroring only works between two devices on the same AP or just the same radio. In my case, mirroring worked if Apple TV and iPad were connected to the two different radios in the same IP, but not if connected to the same radio (either one). 

 

If everything works as expected regardless of which radio combination, you can be pretty sure that it's not a controller/AP setting; it must be something in your wired network not passing on multicasts between the wired network and AP/wireless. You could then experiment with connecting the Apple TV to the wired network (which I advise to do in any case for long term success) to see if that makes a difference. 

 

Also, see free app "Bonjour Browser" for Mac/Windows and its free iOS equivalent called "Discovery" which enable you to see Bonjour service advertisements, which can be very useful in troubleshooting.


Good luck

Highlighted
Occasional Visitor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

That also brings me to another issue. You mentioned having the appletvs hard wired. My original plan was to have the appletvs be wired while the ipads wireless. I wasn't sure how that would work with bonjour being that they would be on different subnets. How did you get that to work?

Highlighted
Valued Contributor

Re: 5.7.0.3 problem-- AirPlay mirroring non-functional on same access point

The eventual plan is multiple subnets to break up the broadcast domain with a Bonjour gateway or router of some type making the Apple TV / Airplay announcements go on all subnets, but for now I just have a VLAN 30 which is for iPads and Apple TVs, and I have a VSC with a wireless network for the same devices which egresses on the same VLAN, wired or wireless.

It's easier than that sounds.