M and MSM Series
cancel
Showing results for 
Search instead for 
Did you mean: 

GMS 5.7 Database

 
Highlighted
FoufAta
Occasional Contributor

GMS 5.7 Database

Hi,

I am using the Guest Management Software version 5.7 on SQL 2008

 

We are migrating our SQL to 2012 and later on to 2014

 

Please can i know if there is any problem migrating the GMS database to SQL version 2012 or 2014?

 

I could not find the database compatibility within the documention.

 

Thx

1 REPLY 1
Highlighted
Arimo
Respected Contributor

Re: GMS 5.7 Database

Hi

 

I really have to advise against the upgrade. GMS 5.7 is tested and supported only on MS SQL 2005 and 2008. It will never be tested on other versions.

 

What this means in practice is that we cannot guarantee the functionality on those platforms. Consequently if you run into problems, we won't be able to support you. You're better off keeping an isolated system with current MS SQL 2008 in one corner of your server room.

 

Database compatibility is listed in the 6.3 & 6.4 Admin guide page 10:

 

"The Guest Management Software has been tested with the following third-party database engines:


• PostGRE SQL 8.3.7 (Linux). This is the recommended external database.
• Microsoft SQL Server 2005 or 2008 (Windows).
• Oracle XE 10.2.0.1-1.0 (Linux).
• MySQL Standard 5.0.51 (Linux)."

Since the latest version isn't supported on >2008, it's easy to see the older ones aren't either.


HTH,

Arimo
HPE Networking Engineer