M and MSM Series
cancel
Showing results for 
Search instead for 
Did you mean: 

Guest WiFi not getting an IP address only 169 Address (MSM 760)

 
Highlighted
joekober
Occasional Contributor

Guest WiFi not getting an IP address only 169 Address (MSM 760)

Good Morning,

I am hoping you can point me in the right direction.

I have a MSM 760 controller which currently has 2 SSIDs with just WPA2 on a untagged VLAN which is working fine and gets a 10.10 address,

We then have another SSID called Guest1 which is on a tagged VLAN 150 which is then assigned a 10.130 address on our DHCP server (MSM is a relay) - This authenticates with a Radius Server.

Now i have tried to make a SSID called Guest2 which is tagged on VLAN 140 and i want this as a centralised guest network which uses HTML portal to authenticate.  The problem i have with this is that clients are not getting an IP address from the DHCP relay at all.  Instead they're getting a 169 address.  I have checked every switch and copied any ports which has the 150 working vlan.  

Any ideas why Guest2 isnt working?

Thanks

1 REPLY 1
Highlighted
NeilR
Esteemed Contributor

Re: Guest WiFi not getting an IP address only 169 Address (MSM 760)

To use HTML authentication you are forced to enable access control as well. This brings all traffic back to the controller before sending it out the VLANS set in VSC egress mapping, so these need to specificed and also the vlans need to be set on the controller ports - otherwise the traffic will not reach your DHCP server. 

With WPA and no access control, the connection is offloaded at the AP and vlans on the switch its connected to.

Alternatively you could use the MSM's DHCP server, but you will still need to send the traffic somewhere from the controller