M and MSM Series
cancel
Showing results for 
Search instead for 
Did you mean: 

MSM422 on VLAN

 
SOLVED
Go to solution
Highlighted
p3rlphr33k
Occasional Advisor

MSM422 on VLAN

I have a strange question regarding the MSM760 mobility controller and MSM422 Colubris-APs. The default vlan (7.X) is almost full. we are adding 22 AP's so they will need to obtain IP's from a new range. I have setup VLAN6 (12.x) for the AP's each port the AP's are connected to I have untagged vlan6 and tagged vlans 2-5. The AP's seem to be jumping to which ever vlan they feel like and getting IP's from the 2-5 vlans NOT the vlan6. Is there a way to accomplish what I am trying to do? That is have access point's in there own vlan while serving other vlans.

vlan1 = 7.x (default vlan)
vlan2 = 8.x (guest1) <--tagged
vlan3 = 9.x (guest2) <--tagged
vlan4 = 10.x (Admin) <--tagged
vlan5 = 11.x (phones) <--tagged
vlan6 = 12.x (access points) <--untagged-APs need to be here
1 REPLY 1
Highlighted
Fred!
Trusted Contributor
Solution

Re: MSM422 on VLAN

Yes, the default behavior is what we can call "plug and play", which means that the AP is free to decide on which VLAN to connect especially if facing a trunk port (with multiple VLANs and where these VLANs all come back to the MSM controller).

The only way you can "force" the AP to go onto a particular VLAN in your case is most likely through the "Provisionning" pages. You can set many different options and one is the VLAN you want the AP to use for discovery.

I guess in your scenario, the best way to do this is to create different groups and place the APs in these groups based on the VLANs you want to use.

Make sure that on the main controller tab, set the provisioning check box so that the controller will be pushing/enforcing provisioning information to the APs (I believe it is in the Management tab if my memory is correct)

Then you go into the different group and set the provisionning information to use the proper VLAN tag, you resynch everything and reboot the APs, they should come back right away on the proper VLAN tag.