M and MSM Series

MSM430 VLAN not working with wireless connections

Occasional Contributor

MSM430 VLAN not working with wireless connections

MSM430 version -12736 firmware



I've been using Cisco access points here for the last 10 years and decided to upgrade to the MSM430. I like the interface but am running into a problem.

Here is what I have:

VLAN 1 = Employees (tagged on port 1)

VLAN 2 = Guests (tagged on port 1)


VSC "Employees" egress VLAN set to 1

VSC "Guests" egress VLAN set to 2


The MSM430 connects to an HP switch that is set to have VLAN 1 untagged and VLAN 2 tagged

Management computer is on VLAN 1



The wireless connections on VLAN 1 often timeout, as if they can't make connection to the DHCP server on VLAN 1. On the Cisco AP, I always set VLAN 1 as the default VLAN. Everything has always worked (and still does). But, on the MSM430, I can't assign VLAN 1 as the default. When I try to do that, I get an error "the management vlan is invalid because it is currently used by wireless clients." I'm not sure if that has anything to do with it or not.



If I set the port on the switch to tag both VLAN 1 and VLAN 2, wireless users can connect on both VLANs but I'm unable to access the management web portal.


I know there must be something simple that I'm doing wrong. As I said, this system has been working for 10 years with the Cisco access points, but I'm just running into trouble with this.


Thanks for the help.

Fredrik Lönnman
Honored Contributor

Re: MSM430 VLAN not working with wireless connections

Skip the egress VLAN for VSC Employees and they will be bridged to the ethernet port untagged.

CCIE Service Provider
MASE Network Infrastructure [2011]

Occasional Contributor

Re: MSM430 VLAN not working with wireless connections

That worked great! Thank you. Is this the correct practice? I just want to make sure I'm not doing anything wrong in configuring it like this. I'm not entirely sure how setting the default VLAN in the Cisco AP's relates to this, but this did solve the problem for me and I appreciate you taking the time to respond.

Thanks again.