M and MSM Series
cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless network a mess; drop connections, high latency; bad roaming; iperf jitter, lost datagrams

 
Highlighted
ONVZ
Advisor

Wireless network a mess; drop connections, high latency; bad roaming; iperf jitter, lost datagrams

Hi all,

 

MSM 765zl firmware 6.0.2.0-15497, APs MSM430s

APs connected to 'AP'-switch 2910al, which is connected to core-switch 5412zl with 765zl-module.

3 SSIDs with WPA2/PSK, authentication/access controlled, bound to both radios

1 SSID with 802.1x, only auhentication controlled, W2003 IAS/Radius server, W2K8 Domain, bound only to radio1 5Ghz.

Channel and power choice, tried static and dynamic, 20 Mhz

Band steering, key caching for roaming by client.

 

Clients Dell Latitude E7440 with Intel 7260 Wlan adapter/Dell Latitude E6430 with Intel 6205 Wlan adapter.

WLAN adapter drivers: Intel, tried several versions 15.x.x - 16.x.x

Wlan adapter settings: power management off, IPv6 off, bluetooth off, roaming tried normal-highest, transmit power low-highest

 

We have had a site survey twice which indicate good coverage. Interference, loud signal detected on 2.4Ghz.

Thats the reason the main SSID is only bound to radio 1.

 

But still APs radio signal still drop, connections get dropped.

Ping show high latency up to 1Ks ms

iPerf test between clients and servers (enclosure/hyperV) show high jitter 1%+ and high lost datagrams.

 

The @#@# thing is that there are (short) periods that the pings and other test show a 'normal' network.

 

Although I can't proove it, my suspicion lies with the authentication.

Tested with 2 clients the only difference being PSK and 802.1x. During ping -t test the 802.1x client (had) dropped its connection and or high latency while the client with PSK on the same AP had normal 1/2ms latency.

After a while the 802.1x terminated completely. After Windows Problem solving it came back. However with the same problems and the PSK-client was immediately showing very high latency, time-outs etc.

To make it even darker... I took both shut clients to my spot with a perfect ping running on my own client. The moment I opened both other clients, my notebook was also experiencing high latency and request time-outs.

 

Has anyone any idea, please !!! :)

 

Thanx Jaap

 

 

1 REPLY 1
Highlighted
Z273
Frequent Advisor

Re: Wireless network a mess; drop connections, high latency; bad roaming; iperf jitter, lost datagra

Dear user,

 

If you are using intel card, please take note of this http://www.intel.com/support/wireless/wlan/sb/CS-034875.htm

 

I believe this might be the cause of your "network a mess", Intel mistakenly set uapsd a power save sub-feature.

 

If you google "intel driver uapsd problem" you can look further more into the symptoms others users had.

 

I rarely visit the forum here but I think I should do more.

 

Cheers.