MSA Storage
Showing results for 
Search instead for 
Did you mean: 

4/16 SAN sw - no network connection

Go to solution
Andras Ordogh
Valued Contributor

4/16 SAN sw - no network connection

Hello All,


we have an old (configured 3-4 years ago) 4/16 switch (os ver. 3.5).

i try to check config, but i didn't know the ip addresses, so i used a

serial cable and a terminal.

I changed ip (it was the default: with ipaddrset, then

I checked the config with ipaddrshow, everything seems to be good,

but there is no network connection! i tried to ping, telnet, web, I checked

port 22, 23, 80, 443 but nothing. I tried via switch or directly pluged

the cat5 to my notebook.

I checked ipfilter with "ipfilter –-show", it said every port are permitted...

I didn't tried to reboot or switchDisable and switchEnable, because

this switch still working... I think reboot not necessary for changing an ip address...


Any idea?


thanks / regards

Occasional Visitor

Re: 4/16 SAN sw - no network connection

Andras, if I recall correctly, once you change the IP of a switch, you need to reboot it for it to take effect.  Quickest way to verify this is to ping the new address that you have assigned to it and then if that does not work, ping the address.  I am thinking you will find that it still replies to and not the new address, until you rebot the switch. 

Johan Guldmyr
Honored Contributor

Re: 4/16 SAN sw - no network connection

ipaddrshow in FOS 6.3 does not mention that you have to reboot the switch. Maybe it was different in yours. Are you on 3.5 or 5.3 or what?
Did you run ifmodeshow/ifmodeset too? If not, do check them out.
Andras Ordogh
Valued Contributor

Re: 4/16 SAN sw - no network connection

hello MarSch, Johan!

first of all, sorry for my late reply, but i got maintance window only now!


yes, i had to reboot switch, and now its's working!


stange, because before reboot, i tried to ping the orig ip ( and there was no answer....
i dont know why have to reboot a switch to change ip address...


thank you again!

(and yes, the version is 5.3 not 3.5 i misspelled :) )


Johan Guldmyr
Honored Contributor

Re: 4/16 SAN sw - no network connection

Thanks for getting back! Glad you got it working agian.

Maybe, this is a 'feature' in FOS 5.3?