MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Brocade Switch Fill Word Configuration and er_bad_os errors

 
DataHammer
Occasional Contributor

Brocade Switch Fill Word Configuration and er_bad_os errors

We are receiving a ton of er_bad_os errors (millions in a matter of days) on all ports connected to our EVA p6300. I can't seem to pry any information out of HP support on what port settings are appropriate when using brocade switches (bc I didnt buy the switches from them). I suspect the problem is in the Fill Word configuration. Any advice would be appreciated

 

Here's how they are configured (I believe everything is brocade default)

 

PHL-FCSW-01:admin> portcfgshow 17
Area Number: 17
Speed Level: 8G
Fill Word(On Active) 0(Idle-Idle)
Fill Word(Current) 0(Idle-Idle)
AL_PA Offset 13: OFF
Trunk Port ON
Long Distance OFF
VC Link Init OFF
Locked L_Port OFF
Locked G_Port OFF
Disabled E_Port OFF
Locked E_Port OFF
ISL R_RDY Mode OFF
RSCN Suppressed OFF
Persistent Disable OFF
LOS TOV enable OFF
NPIV capability ON
QOS E_Port AE
Port Auto Disable: OFF

Rate Limit OFF
Mirror Port OFF
Credit Recovery ON
F_Port Buffers OFF
Fault Delay: 0(R_A_TOV)
NPIV PP Limit: 126
D-Port mode: OFF

1 REPLY 1
Johan Guldmyr
Honored Contributor

Re: Brocade Switch Fill Word Configuration and er_bad_os errors

Hi, 

 

if you have an 8G port in an 8G switch you probably need to set a portcfgfillword. Perhaps set for one port, wait a while and see if the encounter stops increasing (rapidly).

 

Have you tried setting 3?

 

http://h30499.www3.hp.com/t5/HP-BladeSystem-Virtual-Connect/4G-Qlogic-on-8G-Virtual-Connect-problem/td-p/2305959#.UJC8i8Nxye4

 

"For most environments, Brocade recommends using Mode 3, as it provides more flexibility and compatibility with a wide range of devices."