MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Browser Requirements for HP 8/20q QLogic Fiber Channel Switch

 
Brett Emery
Advisor

Browser Requirements for HP 8/20q QLogic Fiber Channel Switch

While a couple of years ago I was able to browse the web interface of the 8/20q Fiber Channel switches, now when attempting it appears java starts to load, by showing a large grey backaround, but then never proceeds.     We don't even get an authentication prompt.   When using IE, it hangs at 50% CPU, FF simple does nothing.         The FC switches are on the latest 8.0.14.03.00 firmware.

 

I've tried several versions of Java , including 1.4.2, 1.5, 6, etc...   As well as several browsers under several OS's (Xp, Win2003), none can get the 8/20q HTTP interface to open. 

 

Does anyone have the exact supported java and browser version requirements?  Thank you!

 

3 REPLIES 3
Brett Emery
Advisor

Re: Browser Requirements for HP 8/20q QLogic Fiber Channel Switch

I found the workstation requirements:

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c02256370/c02256370.pdf?jumpid=reg_R1002_USEN

Unfortunately, we've met those requirements however "QuickTools" will still not launch, here is the java exeption that occurs:

 

Java(TM) Plug-in: Version 1.4.2_13
Using JRE version 1.4.2_13 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\bemeryProxy Configuration: No proxy----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
java.lang.UnsupportedClassVersionError: applet/Common (Unsupported major.minor version 49.0)    at java.lang.ClassLoader.defineClass0(Native Method)    at java.lang.ClassLoader.defineClass(Unknown Source)    at java.security.SecureClassLoader.defineClass(Unknown Source)    at java.net.URLClassLoader.defineClass(Unknown Source)    at java.net.URLClassLoader.access$100(Unknown Source)    at java.net.URLClassLoader$1.run(Unknown Source)    at java.security.AccessController.doPrivileged(Native Method)    at java.net.URLClassLoader.findClass(Unknown Source)    at sun.applet.AppletClassLoader.findClass(Unknown Source)    at java.lang.ClassLoader.loadClass(Unknown Source)    at sun.applet.AppletClassLoader.loadClass(Unknown Source)    at java.lang.ClassLoader.loadClass(Unknown Source)    at sun.applet.AppletClassLoader.loadCode(Unknown Source)    at sun.applet.AppletPanel.createApplet(Unknown Source)    at sun.plugin.AppletViewer.createApplet(Unknown Source)    at sun.applet.AppletPanel.runLoader(Unknown Source)    at sun.applet.AppletPanel.run(Unknown Source)    at java.lang.Thread.run(Unknown Source)java.lang.UnsupportedClassVersionError: applet/Common (Unsupported major.minor version 49.0)    at java.lang.ClassLoader.defineClass0(Native Method)    at java.lang.ClassLoader.defineClass(Unknown Source)    at java.security.SecureClassLoader.defineClass(Unknown Source)    at java.net.URLClassLoader.defineClass(Unknown Source)    at java.net.URLClassLoader.access$100(Unknown Source)    at java.net.URLClassLoader$1.run(Unknown Source)    at java.security.AccessController.doPrivileged(Native Method)    at java.net.URLClassLoader.findClass(Unknown Source)    at sun.applet.AppletClassLoader.findClass(Unknown Source)    at java.lang.ClassLoader.loadClass(Unknown Source)    at sun.applet.AppletClassLoader.loadClass(Unknown Source)    at java.lang.ClassLoader.loadClass(Unknown Source)    at sun.applet.AppletClassLoader.loadCode(Unknown Source)    at sun.applet.AppletPanel.createApplet(Unknown Source)    at sun.plugin.AppletViewer.createApplet(Unknown Source)    at sun.applet.AppletPanel.runLoader(Unknown Source)    at sun.applet.AppletPanel.run(Unknown Source)    at java.lang.Thread.run(Unknown Source)

Ricknsa
Frequent Advisor

Re: Browser Requirements for HP 8/20q QLogic Fiber Channel Switch

So here we are with the same problem 2017, 2 days of trying to load JAVA so I can use my Fibre Channel Swich, and I still cannot get the GUI to come up. I really want to know what we are suppose to do with these if we cannot configure them? HP what do you suggest, or is this one those things that we are just out of luck on? Should we throw every thing that uses JAVA in the trash?

AHECit
Occasional Visitor

Re: Browser Requirements for HP 8/20q QLogic Fiber Channel Switch

You need Java 7u55 and then maybe j2sdk-1_4_2_19, and maybe and older version of Mozilla - i'm using 45.0.1

ok, it's a pain in the @$$ and HP should not use java enabled broswer applications for management...PERIOD!