MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Command View Remote Access

 
CA762524
Occasional Visitor

Command View Remote Access

I'm trying to connect to my VA7400 from my desktop (Win2K Pro). I added my workstation's IP to the access.dat file on the server hosting Command View (V.1.04), however I still get the "401 Authorization Required" error message.

What am I missing ??
4 REPLIES 4
kris rombauts
Honored Contributor

Re: Command View Remote Access

Hi Kevin,

adding your W2K pc's IP address to the access.dat file and stop/starting the hostagent on the server that has CommandView running should be enough in a standard config.


The best way to verify if the web server on the host that runs CommandView is working is connect to http://server_ip_address:4096 , this should give you this message in the browser :

"(c) Copyright 2000-2002 - Hewlett-Packard Company hp StorageWorks CommandView SDM web server"

If this does not work then the Cmdv webserver does not run and you should change the c:\sanmgr\commandview\server\config\PanConfigParams.txt file and edit it so that the parameter called WEBSERVER_ENABLED is set to true. I think this is ok in your config given the error message you get back.

The above example is for a config where the webserver runs on a Windows server, not sure on what OS your CommandView runs (UX or Windows) but the file to edit (PanConfigParams) is the same.

Other then this from the network point of view it seems to be ok because you get a reply back from the web server.
If the above does not help, try to put *.*.*.* in the access.dat just for a test to allow all IP addresses to connect to the Cmdv webserver.


HTH

Kris


Eugeny Brychkov
Honored Contributor

Re: Command View Remote Access

Kevin,
here's something in addition what Kris has mentioned
http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x977b85079106d71190050090279cd0f9,00.html
Eugeny
kris rombauts
Honored Contributor

Re: Command View Remote Access

Hi Kevin,

since you did not specified the OS that runs on the host connected to the VA7400 the test below might not be valid since it is intended for Windows hosts only.

Try to run the remote acces locally on the Windows server itself by pointing your browser to http://server_ip_address:4096 or http://server_ip_address:4096/Launcher.html"
to verify if acces locally is working fine or not.

You can also use the servers hostname, 127.0.0.1 or localhost, all of this should work locally.

regards, Kris
CA762524
Occasional Visitor

Re: Command View Remote Access

Thanks for the info everyone - I managed to get it going. Weird though, the first few times I tried connecting I was never prompted to install the Java applet - probably one of the significant reasons it wasn't working. I rebooted my client workstation after confirming the correct entries in the access.dat, etc. and once my workstation was up I tried the http://server_name:4096/Launcher.html and was prompted to install the Java applet. Once that completed the GUI fired up right away and I was able to remotely view my VA7400. Don't exactly know what was going on there, but it's working now.

Thanks again to all!