MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HP MSA 2040 performance

 
TTechnology
Occasional Contributor

HP MSA 2040 performance

Hi there,

 

we have just bought and installed HP MSA 2040 21TB iSCSI bundle with 10GB SFPs. It comes with 24 x 900GB 10K drives

 

configured one test RAID10 and presented it to ESXi 5.5. The server is connected to Juniper switches over 2 x 1 GB nics. The MSA is connected to the same Juniper over 2 x10GB nics. 

 

Then I created first volume and used it as first VMFS datastore. 

AFter installing test Windows 2012 R2 server I decided to test performance by copying one large ISO file from/to the same VMDK file. 

 

The copy process is not as fast I expected - about 100MB/s, but more strangely I can see that after copying half of the larg 3GB file the copy rate drops down to 10MB..

 

Screen Shot 2014-09-12 at 1.29.12 pm.png

 

 

That is really strange behavior. I tried to change the cache settings for the volume from Write-back to Write-though, but that didn't change anything. I also tried different multipathing policies on the storage, but again - same result.

 

I am really stuck here. Anyone has any idea how to fix that?

2 REPLIES 2
StephenWagner7
Frequent Advisor

Re: HP MSA 2040 performance

Let's see if we can help you out here!

 

Please let me know if you've done the following:

 

1. Updated the SAN to the latest firmware.

2. Logged in to the web interface, and confirmed there are no errors in regards to cache or controllers.

3. Confirm that a controller isn't going offline when the speed decreases.

4. Is the same controller connect twice to the Juniper switch, or does the unit have dual controllers (each controller connected to the switch).

5. Are you using VLANs at all? Any specialized systems/technologies running on the switch?

 

Also, as for ESX config:

 

1. Are you using multipathing or LAG for the connection from the host to the switch? Are you using a single subnet or multiple subnets, please also let me know if you are using iSCSI port binding or not.

2. Have you confirmed that ESXi is reporting each path to the VMFS datastore/volume?

3. Have you configure roundrobin and set the IOPS as per HP's VMWare MSA 2040 document?

 

Since you mentioned at the beginning that it's running at 100MB/sec at first, I'm thinking there are issues with your config connecting the server to the switch (you might be using LAG instead of multipathing). You should see hit hitting close or higher then 200MB/sec.

 

Also, while I do have experience with the MSA 2040, I haven't played with RAID10 on the unit yet. Can someone let me know if there is a RAID initialization process for RAID10? If so, has the RAID initialization process completed on your unit?

 

P.S. I wouldn't play with the cache settings on the unit. If you have dual controllers, I've read that changing the cache options could cause corruption in certian environments when a controller failure occurs. Since you noticed it has no effect, please change it back to default settings.

 

I'll wait to hear back re: the questions above, let's see if we can help out with this.

 

P.S. Do you have any SFP+ modules, or SFP+ DAC cables you could test a 10G link on a server with?

StephenWagner7
Frequent Advisor

Re: HP MSA 2040 performance

Any update? Did you resolve the issue?