MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Help with donated EMA12000 / HSG80 - No CLI prompt !!!

 
vincentvije
Occasional Advisor

Help with donated EMA12000 / HSG80 - No CLI prompt !!!

Please, I got a bid donation : several EMA12000, DS10 to GS80, SAN switches and more.

 

Well, the problem is with the EMA12000 / HSG80.

I connected its RJ12 port to the COM port on my PC, started hyperterminal : 9600 baud, 8 data bits, 1 stop bit, and no parity.

 

And... no CLI prompt.

 

I tried to power up EMA12000 / HSG80 with hyperterminal already waiting, but no luck.

 

I searched a very lot of time all the HP documentation on EMA12000, HSG80 and other, but found nothing.

 

Then I'm lost.

In front pannels, no faults, no problem, no alarm, all the controllers and disk seem al right in every EMA12000.

But whatever HSG80 I connect o hyperterminal (or other software), I get no CLI prompt.

 

With CLI, I could manage configs and more. But without CLI, where to start ?

All the other material donated is ok, I managed to get all of them working good, I'm just stuck since some time with this CLI prompt and theses EMA12000.

 

Thansk for your help !

 

Vincent MARECHAL

 

 

 

4 REPLIES 4
vincentvije
Occasional Advisor

Re: Help with donated EMA12000 / HSG80 - No CLI prompt !!!

Well, the question could be : how to get the CLI from HSG80.

I put : 9600 baud, 8 data bits, 1 stop bit, and no parity.

Then power up EMA12000. All the hardware seem ok.

But no CLI...

I'm connected between RJ12 (HSG80) and DB9 (PC).

KurtG
Regular Advisor

Re: Help with donated EMA12000 / HSG80 - No CLI prompt !!!

I believe that it was possible (not default) to set a higher baud rate on those controllers. Try 19200 8-n-1

 

KurtG

vincentvije
Occasional Advisor

Re: Help with donated EMA12000 / HSG80 - No CLI prompt !!!

THanks a lot for the answer.

Well, I tried 19200 too.

 

I don't know if the owner could have change to another config the serial port ?

Or if he could have desactivated the serial port ?

Or something else.

All the six hsg80 I tried doesn't give me CLI prompt. But all of them indicated all is all right in th EMA12000.

I've just the caches without batterie, no more.

 

I should  make a factory reset. It seems it's with the #5 OCP button, and plugin the power cord ?

 

Thanks again !

 

Vincent

 

vincentvije
Occasional Advisor

Re: Help with donated EMA12000 / HSG80 - No CLI prompt !!!

Solution found : my cable was inverted.

I had the pinout of Hoffman Labs site, and from a document quoted even in this hp site... but pins 1 to 6 are inverted !!!

 

 

I saw this looking for HSG80 RJ12 pin names, null modem layout and RS232 DB9 pins names.

From these I made my null modem. And it works.

 

But what documents in Internet and Hoffman Labs numbers pins 1 to 6 are 6 to 1.

I think computing engineers are not electronics engineers...

 

Here is the real pinout :

RJ11  <-> DB9

1 : DSR <-> 4 : DTR

2 : RXD <-> 2 : RXD

3, 4 GND <-> 5 : GND

5 : TXD <-> 3 : TXD

6 : DTR <-> 4 : DTR, 6 : DSR, 8 : CTS

This is exactly what sites publicate but inverting RJ12 pin numbers. I'm 100% sure and electronics engineer so things are this way, and not just a point of view.

 

Please note that it can be cabled differently for DB9 signals DTR, DSR, CTS.

That's why MMJ is different, as one can see on HP site.

You just have to make shure it is null modem. Mainly crossing RXD and TXD, and forcing one way DTR, DSR and DB9 and CTS for detection.

 

Well, I don't know why RJ11 is inverted on this pinout... surely because one site publicated inverted and others copied information.

 

Regards,

 

Vincent MARECHAL