MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MPIO FF for MSA1500

 
Mike Drobick
Frequent Advisor

MPIO FF for MSA1500

I seem to have lost my post, so I'm going to throw this up again.

We have an MSA1500 with (3) MSA30 shelves and (2) MSA20 shelves running firmware 5.02/1.48. There are (4) servers connected running Windows Server 2003 w/SP1. We have redundant Brocade 4GB switches with the second switch currently turned off.

When I try to load MPIO Basic 1.1, I get an NTVDM error.

I have been searching everywhere, but cannot find the full featured version for MSA although the full featured MPIO Manager software hints that there is a version for the MSA.

So, I guess my questions are:

Any ever get the NTVDM error trying to install MPIO 1.1 for the MSA1500?

Anyone know where the full featured version is for the MSA?

Is there something in my configuration that isn't jiving? When I downloaded firmware 5.02, it came with 1.42 for the MSA20, but the MSA20 itself shipped with 1.48 so I left it.

Any help is greatly appreciated.

Mike
4 REPLIES 4
Uwe Zessin
Honored Contributor

Re: MPIO FF for MSA1500

A full featured MPIO for the MSA would be required if the array where capable of running Active/Active and while it has been promised for a looong time, it is still not there, so don't be surprised if you can't find the FF-MPIO.
.
Mike Drobick
Frequent Advisor

Re: MPIO FF for MSA1500

Thanks for the feedback.

Well then, I guess my next question is...how do I get multipath support in my current environment?

Do I have something getting in the way of the Basic MPIO 1.1 that is causing it to crash the NTVDM? Should I not have gone up to FW 5.02?

I have Veritas Storage Foundation installed with the DMP option, but I didn't think it would interfere as it turns out, the MSA1500 isn't supported by DMP anyhow.

I appreciate any help!

Mike

Re: MPIO FF for MSA1500

Hi Mike,

I had the same problem. The solution is easy. Start the software file (sp....) on a windows XP desktop, it will unpack the software.

Now copy this folder to your server and start the installation. This will work fine. I think there is a compatibility problem with the archive software used.

Good luck!

Arjo
Mike Drobick
Frequent Advisor

Re: MPIO FF for MSA1500

I hate when I do this...

Thanks for the reply. Yes, I quickly realized that the NTVDM error was just from unpacking the software. I unpacked from another system, threw up on a CD, and was on my way.

The real problem did surface in that Veritas Storage Foundation for Windows also has the option to run their "DMP" or Dynamic MultiPathing. It in turn loads their own version of the MPIO driver that is NOT supported to run against the MSA1500. I tried to load the HP version over the top, but it didn't work. I suspect WFP stepped in because the Veritas files were newer. The only fix I found was to unload the whole VSFW and reinstall without the DMP option. For 4 machines, a waste of 3 hours total.

So, the answer is:

Unpack on another machine to get around the NTVDM error.
Don't install the Veritas DMP option when using the MSA1500.

Mike