MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA 2012i issue

 
E155
Occasional Contributor

MSA 2012i issue

Hi all.
I have an old dualcontroller MSA2012i with 2 encloseres.

System Information
------------------
Vendor Name      : HP StorageWorks
Product ID       : MSA2012i
Product Brand    : MSA Storage
SCSI Vendor ID   : HP
Enclosure Count  : 3

Controller A
------------
Serial Number           : 3CL925S477
Hardware Version        : LCA 56
CPLD Version            : 27
Cache Memory Size(MB)   : 1024
Host Channels           : 2
Host Bus Type           : iSCSI
Drive Channels          : 1
Drive Bus Type          : SAS

Controller B
------------
Serial Number           : 3CL818C412
Hardware Version        : LCA 56
CPLD Version            : 27
Cache Memory Size(MB)   : 1024
Host Channels           : 2
Host Bus Type           : iSCSI
Drive Channels          : 1
Drive Bus Type          : SAS

Controller A Versions
---------------------
Storage Controller CPU Type   : Celeron 566MHz
Storage Controller Firmware   : J212P01
Storage Controller Memory     : F300R22
Storage Controller Loader     : 15.010
Management Controller Firmware: W421R46
Management Controller Loader  : 12.013
Expander Controller Firmware  : 3218
CPLD Revision                 : 27
Hardware Revision             : LCA 56
Host Interface Module         : 50
Host Interface Module Model   : 2

Controller B Versions
---------------------
Storage Controller CPU Type   : Celeron 566MHz
Storage Controller Firmware   : J212P01
Storage Controller Memory     : F300R22
Storage Controller Loader     : 15.010
Management Controller Firmware: W421R46
Management Controller Loader  : 12.013
Expander Controller Firmware  : 3218
CPLD Revision                 : 27
Hardware Revision             : LCA 56
Host Interface Module         : 50
Host Interface Module Model   : 2

 I have planed sheduled maintanance and rebuild with full configuration reset.
Thus I shut down storage controllers and has powered him off.
After power on one of controllers is dissapeared.


I power off storage again and remove it from rack to my lab.

  1. After assebly in lab I power on him but management network connection doesnt work to any modules.
    Im trying connect by console cable.

    Controller module A - doesnt answer.
    Controller module B - shows booting process, but CLI session hangs up after commands like:

  • show versions
  • show configuration

result for show versions was:

# show versions
Controller A Versions
---------------------
Storage Controller CPU Type   : No_data
Storage Controller Firmware   :
Storage Controller Memory     :
Storage Controller Loader     :
Management Controller Firmware:
Management Controller Loader  :
Expander Controller Firmware  : Not Ready
CPLD Revision                 :
Hardware Revision             :
Host Interface Module         :
Host Interface Module Model   :

Controller B Versions
---------------------
Storage Controller CPU Type   : No_data
Storage Controller Firmware   :
Storage Controller Memory     :
Storage Controller Loader     :
Management Controller Firmware:
Management Controller Loader  :
Expander Controller Firmware  : Not Ready
CPLD Revision                 :
Hardware Revision             :
Host Interface Module         :
Host Interface Module Model   :

or sometimes some strange like that: 

each time this output dlay from entering command to output very long - a few minutes.

If i enter show configuration - system hangs up finally.

If i enter restore defaults - system hangs up finally.

2. A also tried to change power supplys and place controller boards to other enclosures chasis.
   Still the same.

3. Have tried to flash controller by console cable:
   When A/B modeles installed - FW sending hangs up in a few seconds after start.
   When I remove module A and upload FW by console cable i got message

File received OK
SC code on MC processor.
FILE CORRUPT!
Hit <ENTER><ENTER> to continue.


I tried download FW for single controller array - the same. Aslo i have compred this FW (MC and SC - they are idenntical)

No more ideas. :(  Please help.

3 REPLIES 3
www_tank
Occasional Visitor

Re: MSA 2012i issue

try to get one controller off and restart MSA

I faced with the similar problem. MSA didn't start or after srarting didn't show anything (disks, vdisks, volumes) I had been working with single controller for several month moving all data somewhere alse. Finally I have upgraded empty MSA for new firmware (with 3 stairs) Now I am happy and I wish happiness to you :)

 

E155
Occasional Contributor

Re: MSA 2012i issue

of cousrce I tring several times to start MSA with 1 controller. The same. 

1 - hang up. 2 - didnt answer 

kyakhta
Visitor

Re: MSA 2012i issue

Did you found solution? I'm facing exatly the same problime since last week. Will greatly appreciate any help.

 

Alex