MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA 2050 and Oracle VM server release 3.4.3

 
Highlighted
andyhaigh
Visitor

MSA 2050 and Oracle VM server release 3.4.3

Hi,

We have connected up our new MSA 2052 to a pair of servers running Oracle MV Server 3.4.3 via a couple of SAN switches and we without any LUN's connected we are seeing the enclosure listed after a lsscsi command, seems to appear as LUN 0

[1:0:2:0]    enclosu HPE      MSA 2050 SAN     V270  -
[1:0:3:0]    enclosu HPE      MSA 2050 SAN     V270  -
[2:0:2:0]    enclosu HPE      MSA 2050 SAN     V270  -
[2:0:3:0]    enclosu HPE      MSA 2050 SAN     V270  -

When I map two LUN's  - LUN 0 and LUN 1 to the servers I end up with this:

[1:0:2:0]    enclosu HPE      MSA 2050 SAN     V270  -
[1:0:2:1]    disk    HPE      MSA 2050 SAN     V270  /dev/sdbr
[1:0:3:0]    enclosu HPE      MSA 2050 SAN     V270  -
[1:0:3:1]    disk    HPE      MSA 2050 SAN     V270  /dev/sdbs
[2:0:2:0]    enclosu HPE      MSA 2050 SAN     V270  -
[2:0:2:1]    disk    HPE      MSA 2050 SAN     V270  /dev/sdbt
[2:0:3:0]    enclosu HPE      MSA 2050 SAN     V270  -
[2:0:3:1]    disk    HPE      MSA 2050 SAN     V270  /dev/sdbu

LUN 0 still shows as enclosure and LUN 1 is displayed correctly.

The scsi-rescan command issued shows it is changing the [2:0:3:0] entry from enclosure to direct-access

sg74 changed: device 2 0 3 0 ...
from:Enclosure                         : 00
to: Direct-Access      Model: MSA 2050 SAN     Rev: V270
      Type:   Enclosure                        ANSI SCSI revision: 06

but LUN 0 does not show up as a disk.

I could create a dummy LUN 0 of 1GB and apply this to get round the enclosure issue but would rather fix it correctly.

Could anyone provide any guidance on how to resolve this.

Thanks

Andy

 

 

2 REPLIES 2
Cali
Honored Contributor

Re: MSA 2050 and Oracle VM server release 3.4.3

The Controller already use LUN 0.

So start with the first Volume by LUN1.


======================
That was not planned in this way.
andyhaigh
Visitor

Re: MSA 2050 and Oracle VM server release 3.4.3

There is also an MSA2040 conncted to these servers but that does not show as an enclosure, would that just be due to different behavior of the firmware installed on each SAN?

In regards to the MSA 2050 and other SAN's there are comments about creating a specific device section in multipath.conf, is there a set configuration for the MSA 2050?

Thanks

Andy