MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1000 with active/active FW - 2nd controller status offline

 
michel_m
Advisor

MSA1000 with active/active FW - 2nd controller status offline

Hello,

Here is my configuration :
- msa1000 with active/active firmware 7.00
- 2 integrated SAN switchs 2/8
- servers = VMware esx 3.0.1 with only 1 hba connected (qlogic)
- using hp sim 5.1sp1 with hp agents v7.70 for esx 3.0.x

This is working correctly, but the hp agents are reporting an error with the 2nd controller ("No paths are available to this controller").

This issue seems to be due to the fact that the server is only connected with the first controller through the first switch 2/8, and isn't able to see the 2nd controller which is linked to the other switch 2/8.

How can I get rid of this minor health status ?
20 REPLIES 20
John Kufrovich
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Michael,
Can you attach a >show tech_support from the MSA controller.
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Please could you explain me what you expect me to do.
I can't see a CLI command like "show tech_support"
(I'm connected through the "HP Array Configuration Utility CLI" on a Windows 2003 server which is linked to the 2nd switch-controller.)
Rob Leadbeater
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Hi,

That command needs to be done from the CLI via a terminal emulator (eg Hyperterminal) - with the serial cable connected to the port on the front of the MSA...

Cheers,

Rob
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Thanks Rob,
Unfortunately I can't find this cable. I need to search for it... Is there something I can check before ?
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Well, can't get this cable to connect to the console.
But, I used the CLI interface on the Windows server (HBA connected to the 2nd switch) to run this command :

=> ctrl chassisname="xxxxxxxx" show

MSA1000 at xxxxxxxx
Bus Interface: Fibre
WWN: 500805F3000EC4F9
Serial Number: P56350GX3QV046
Chassis Serial Number: SGM0424143
Chassis Name: xxxxxxxx
RAID 6 (ADG) Status: Enabled
SSP State: Enabled
Controller Status: OK
Redundancy State: Active
Redundancy Status: OK
Redundancy Mode: Active-Active
Preferred Path Mode: Automatic
Chassis Slot: 2
Hardware Revision: Rev A
Firmware Version: 7.00
Rebuild Priority: Low
Expand Priority: Low
Surface Scan Delay: 3 sec
Cache Board Present: True
Cache Status: OK
Accelerator Ratio: 50/50 (read/write)
Read Cache Size: 128 MB
Write Cache Size: 128 MB
Total Cache Size: 256 MB
Battery Pack Count: 1
Battery Status: OK
Host Bus Adapter Slot: 1

Configuration should be similar on the 1st controller...
Is it sufficient for your diagnostic ?

Thx, Michel
John Kufrovich
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Michel,

19.200, 8, N, 1, no

The cli attaches to the RJ45 slot on the controller.

michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

John, the only cable I'd found wasn't the good one.

The cable shipped with the MSA1000 (#259992-001) has an RJ45Z (not the regular RJ45), that's why I couldn't insert mine...

I'll give an other chance to my researches in the stock on monday.
John Kufrovich
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

You're correct, rj45z. I couldn't remember all the differenct keyed combinations for rj45. Guess I should have opened up the schematic.

Guess, I should have read your first question better.

Since you are not using the second MSA controller or path redundancy. Just disable the second MSA controller in ACU.
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

John, I have 8 servers : that's why I can't disable 2nd controller.
(6 ESX are on the 1st switch, and 2 W2K3 are on the 2nd)
In my case, it should be normal that my servers can't see the other controller, because of single HBA attachement, but the Insight agents are showing up an alert for it...
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

I finaly did it with the correct cable !

Here is attached the 'show tech_support' file done on the 1st controller (used by the 6 ESX servers).

Thanks for your assistance.
John Kufrovich
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Michel,

Thanks for providing the show tech support.

FYI, this report is from the MSA C2(left controller). But it doesn't matter since you are using 7.0 FW.

Just to make sure you and I are on the same page.
ESX servers have one HBA, single FC port to MSA SW1 -> MSA C1.

For the Windows Cluster (clu1 and clu2), single ported HBA -> MSA SW2 -> MSA C2.




michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Yes, you're right, the repport is from the left controller (the one with the windows servers clu1 & clu2). Sorry for that :-}
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Problem is not solved yet...
Stefan Schneeberger
Occasional Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Hi Michael, I have exactly the same problem in my test environment. Have you ever received/found a solution for this? Thank you! Stefan
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

no, still waiting for some help...
Patrick Terlisten
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Hello,

maybe a dumb question, but did you attach power-cords to both of the power-supplies in the MSA1000?

I had a similar problem with a MSA1500cs. Both controllers were online, but SHM reported a failed controller. After adding power to the second power-supply the failure in the SHM went away.

Best regards,
Patrick
Best regards,
Patrick
Stefan Schneeberger
Occasional Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Hi Patrick,
In my case, both power supplies are connected and operational. Thanks anyway!
Patrick Terlisten
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

It was only an idea. But let's wait what michael say's.

Best regards,
Patrick
Best regards,
Patrick
michel_m
Advisor

Re: MSA1000 with active/active FW - 2nd controller status offline

Same for me, Patrick, both power-cords are in place.

Problem seems to be because one switch only communicate with one controller, and my servers have only one HBA. As my firmware is active/active, I might be missing a direct path to the 2nd controller (which is also active).

I just want the insight agents not to report this as a failure...

Michel
Patrick Terlisten
Honored Contributor

Re: MSA1000 with active/active FW - 2nd controller status offline

Hi,

AFAIK is single hba with A/A not supported. Did you setup proper zoning, which is required for VMware?

Best regards,
Patrick
Best regards,
Patrick