MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

P2000 - Could not connect to the admin web page

 
SOLVED
Go to solution
p4c
Occasional Advisor

P2000 - Could not connect to the admin web page

Hi there,

 

We have a P2000 with HP support and since two days, we are unable to connect to the P2000 Web interface.

As soon as we indicate our login/password, the login web page is stuck at the "Loading replicationSetsSet" part.

 

We have try to connect to it with different account but we get the same problem.

The last operation that was made on the P2000 was

 

- Extand a RAID 5 from 3 vdisks to 4 vdisk

- Initiliase another RAID 5 vdisk

 

Since then, we got this problem.

Best Regards,

 

Maxime

IT Technician

11 REPLIES 11
Johan Guldmyr
Honored Contributor

Re: P2000 - Could not connect to the admin web page

Hello,

can you connect to the other controller (in case you have two)?

If not, maybe via the serial port?

It's possible to only restart the 'management controller' via the CLI. Check out the reference guide but I believe it's 'restart mc' or something like that.

p4c
Occasional Advisor

Re: P2000 - Could not connect to the admin web page

Hi Johan,

 

We have the same problem connecting to controller A or B

We have also restart the SAN in order to be able to connect to it, but it was unsuccessful.

I'll try to use CLI client even if i'm not familiar with it.

Johan Guldmyr
Honored Contributor

Re: P2000 - Could not connect to the admin web page

"We have also restart the SAN in order to be able to connect to it, but it was unsuccessful."

 

What did you restart? The P2000?

p4c
Occasional Advisor

Re: P2000 - Could not connect to the admin web page

I'll add that if i wait until the session timeout happen (30 minutes) my session expire and i can get the web interface by clicking on a menu to reset my session.

p4c
Occasional Advisor

Re: P2000 - Could not connect to the admin web page

Yes, we have reboot the P2000.

But we still have the issue.

 

Even after being able to connect to it when the session expire (30 minutes) we have restart the management controller A & B, the we stil having issue.

Johan Guldmyr
Honored Contributor

Re: P2000 - Could not connect to the admin web page

Hm... I wonder what could be the cause for a session to expire. Are you using SSL? Maybe there's a problem with a cert or something.

Some other firewall / networking / routing problem?

If I were you I'd contact HP support and ask for some assistance, maybe the answer is in some log somewhere..
p4c
Occasional Advisor

Re: P2000 - Could not connect to the admin web page

Sorry, i wasn't very clear.

 

whe we try to connect to the web interface of the P2000, we put the login/password, then it start to load the weboage and get stuck at "LoadingReplicationSetSets" part. But if i wait 30 minutes (the session timeout), i can get access to the web interface.

But as soon as i closed the web interface and try to log in, i have the same issue.

 

In conclusion, i've to wait the session timeout of 30 minutes to get an access to the P2000.

But i'm suppose this problem is too weird to find a solution on the forum.

I've check the log file, there is no error/information/critical on it.

 

Thanks anyway for your help.

If someone have another idea, we'll take it or we'll try to get the HP support.

p4c
Occasional Advisor
Solution

Re: P2000 - Could not connect to the admin web page

Hi,

 

We have found the solution for those who get the same problem that us.

It was a tricky one. We had to connect with CLI and delete Volume 1 & 2 from a Vdisk after creating a Snapshot pool.

It seems that the Snapshot pool was completly out of control and refuse to load during the login process on the webpage of the SMU. It's funny since the Snapshot pool process is ok but was stucked on the Replication loading process.

 

But at the end, we can now connect to the P2000.

cdlncw
Occasional Visitor

Re: P2000 - Could not connect to the admin web page

Hi,

 

I am also having a similar issue.

 

When I try to login via the web gui interface on controller 'A' all I get is the dialogue box appear with the following in:

 

"The application is loading"

 

"Loading LicenseSet"

 

After about 10 minutes it times out and I can't access the array via this method.

 

I can however access the array via TELNET, however I'm unsure of the CLI commands and would prefer the web gui interface. This array doesn't have any snapshots or snap-pools configured, so the below fix doesn't really apply to me.

 

Has anyone else experienced this issue and if so what did you do to resolve it?

 

Thanks

 

AnkitM
Trusted Contributor

Re: P2000 - Could not connect to the admin web page

What do you see when you execute #show network-parameters

 

Does it show link speed: Unoknown or Undetermined?

 

If yes, then log in to each controller and execute:

 

#set network-parameters auto-negotiation on link-speed 100mbps

 

then 

 

# restart mc both (from any controller)

 

Wait for 2-3mins and see if it helps.

 

 

Was your question answered correctly? If so, please remember to mark your question Answered when you get the correct answer and award KUDOS! to the person providing the answer. This helps others searching for a similar issue.
Max Sorokin
Regular Advisor

Re: P2000 - Could not connect to the admin web page

Hello,

Yesterday we has the same issue. After switch replace, we unable to login to the P2000 via WEB. The problem was in switch security configuration. We disable Storm Control in our HP 1820 Switch and now everything is ok. For more info please see attachment.

 

BR,

Max

/Maxim