MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

 
Ares7
Occasional Contributor

P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Hello! Help me please. After the update, we got an errors.. During the update, there were no errors.

hp1.pnghp2.pnghp3.pnghp4.pnghp5.png

7 REPLIES 7
Ares7
Occasional Contributor

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Unhealthy Component
-------------------
Component ID: Enclosure 1, Current 12V Loc: lower-IOM B
Health: Degraded
Health Reason: The current sensor's status is unknown or its value is unexpected. It may be unhealthy.
Health Recommendation: - Check in the event log for events related to this component and follow the recommended actions for those events.

Unhealthy Component
-------------------
Component ID: Enclosure 2, Expansion Module B, In Expansion Port
Health: Fault
Health Reason: The enclosure expansion port is inoperable.
Health Recommendation: - Check the SAS expansion cable between enclosures connected through the indicated port, and replace the cable if necessary.
- If this does not correct the problem, check that the modules at each end of the cable are powered up and have good health; replace any faulty controller module or expansion module.

Unhealthy Component
-------------------
Component ID: Enclosure 1, Temperature Loc: lower-IOM B
Health: Degraded
Health Reason: The temperature sensor's status is unknown or its value is unexpected. It may be unhealthy.
Health Recommendation: - Check in the event log for events related to this component and follow the recommended actions for those events.

Unhealthy Component
------------------- Component ID: Enclosure 1, Voltage 5V Loc: lower-IOM B
Health: Degraded
Health Reason: The voltage sensor's status is unknown or its value is unexpected. It may be unhealthy.
Health Recommendation: - Check in the event log for events related to this component and follow the recommended actions for those events.

Unhealthy Component
-------------------
Component ID: Enclosure 1, Voltage 12V Loc: lower-IOM B
Health: Degraded
Health Reason: The voltage sensor's status is unknown or its value is unexpected. It may be unhealthy.
Health Recommendation: - Check in the event log for events related to this component and follow the recommended actions for those events.

seventest
Visitor

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Hi how do you resolve this problem?

i have the same problem after flash 252 firmware

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Did you tried to reboot both management controller at the same time?

if same issue persists then take downtime and reboot storage controllers at the same time

If still same issue persists then try to reflash the firmware where Expander module firmware shown as unknown

If still issue persists then we have to replace the hardware

 

Hope this helps!
Regards
Subhajit

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************************

seventest
Visitor

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Did you tried to reboot both management controller at the same time? YES

if same issue persists then take downtime and reboot storage controllers at the same time YES

If still same issue persists then try to reflash the firmware where Expander module firmware shown as unknown NOT FLASHED, say error

if i flash HPE P2000 G3 MSA Array Systems Controller Firmware TS252P005 or TS252P001 then nothing change exclude version

If still issue persists then we have to replace the hardware

 

but if i sotdown one of the SC, then other work fine

i think the problem with defferent firmware versions in "Expander controller code versions"

because if i start first SC module B then SC A i see old fw version on screenshot

or bad version in Expansion Modules (EMPs). but it not flash with CAMSPR0146_6G_app_4MB_ai.pmc =) say error

i tied power off MSA and reconnect controllers and flash cards and cables 

nothing help =)

 

 

 

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

I have seen the screenshot and it looks to me Controller B internal Expander Controller Code gone back to very old version 1052. It could be issue with Controller B

Please note that Controller internal EXpander Controller is not Enclosure 2 IO modules. They are different. Controller internal EXpander Controller responsible for SAS Out put port or Egress port which we use to connect External Drive enclosures IO modules.

Next suggestion would be,

>> Plan for downtime and Stop Host IO or disconnect Host from MSA

>> Shutdown Controller B

>> Upgrade Controller A to latest firmware TS252P005

>> Disable PFU or Partner Firmware Upgrade on Controller A

>> Power up Controller B and upgrade to TS252P005

>> If still same issue persists then replace Controller B

 

Hope this helps!
Regards
Subhajit

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************************

seventest
Visitor

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

thanks, i try upgrade witout PFU

personal A and B

and have the same issue

B internal Expander Controller Code not upgraded 

we plan replace Controller B (

if we come up with something i write result here :)

Re: P2000 G3 SAS ERROR ": The firmware version is not compatible, HP SPS-CHASSIS 2028"

Yes kindly update with the solution so that whoever following this forum can get the answer. Also mark the forum as resolved once the issue get fixed as well.

 

 

Hope this helps!
Regards
Subhajit

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************************