MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

P2000 G3 new hard disk problem

 
DmitryPrichalov
Occasional Visitor

P2000 G3 new hard disk problem

Hello.

Sorry for my English, but I will try to be clear.
I need to install two new disks in HP2000 G3. At the time of installation, the green indicator lights up and flashes, but after a few seconds they turn off and the orange light starts to glow steadily.
At this time the message appears in the logs:

In the menu "Physical" - "Enclosure 1" (SPS-CHASSIS) in the tab of the graphic display of the disk does not appear, as well as in the Front Tabular tab.  And P2000 works as if there are no new disks installed.
I re-read the manual 2 times, google for three days, but I still cannot understand what I am doing wrong.
I would be grateful for any suggestions.

4 REPLIES 4

Re: P2000 G3 new hard disk problem

What is the Controller firmware version in this P2000?

you can check from CLI by running command,

show versions

Do you have any other free slot in this MSA? Then you can put this new drive in any other free slot and check if same behavior repeats or not? This will tell you if the new drive DOA or Good one.

How many Vdisk created in this MSA?

If all Vdisks in FTOL state, you have no other free slot and you have only one new drive then you can plan for downtime, stop Host IO. Shutdown MSA. Remove one good drive part of the Vdisk and place it to the same slot where you were trying to put the new drive. Then power up the MSA and check both from CLI and SMU if the drive detected or not? This is just to verify whether this is slot issue or drive issue.

 

Hope this helps!
Regards
Subhajit

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************************


Accept or Kudo
DmitryPrichalov
Occasional Visitor

Re: P2000 G3 new hard disk problem

# show version
Controller A Versions
---------------------
Bundle Version: TS250P002
Build Date: Wed Jun 12 09:27:48 MDT 2013

Controller B Versions
---------------------
Bundle Version: TS250P002
Build Date: Wed Jun 12 09:27:48 MDT 2013

Success: Command completed successfully. (2018-11-02 13:03:06)

# show vdisks
Name Size Free Own Pref RAID Disks Spr Chk Status Jobs Job% Serial Number Drive Spin Down Spin Down Delay Health Health Reason Health Recommendation
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
vd01 899.2GB 0B A A RAID5 3 0 64k FTOL 00c0ff14df130000de83295200000000 Disabled 0 OK
vd02 5395.6GB 0B B B RAID6 8 0 64k FTOL 00c0ff14df710000501d7e5300000000 Disabled 0 OK
vd03 1798.5GB 0B A A RAID10 4 0 64k FTOL 00c0ff14df130000ee3b2c5900000000 Disabled 0 OK
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Success: Command completed successfully. (2018-11-02 13:06:16)

 

I have two new drives. I tried to install them in different ports (there are 8 free slots) - it had no effect.
I just took the old disk, which was removed from the MSA about 4 years ago and installed it in place of one of the new disks. The MSA immediately took it to work.
I conclude that the problem is in the new disks, but previously there were no similar problems. What is the probability that the firmware of the MSA is just so outdated that it can not identify a new disk?

 

Re: P2000 G3 new hard disk problem

It's good to always running latest firmware in terms of any component of the MSA. Please find the link to get the same,

www.hpe.com/storage/MSAFirmware 

 

www.hpe.com/storage/DiskEnclosureFirmware

 

Regarding drive detection, you need to make sure you are using HPE supported drives and HPE drive firmware updated. Please find the link to check if the new drives supported or not,

 

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c04315770&lang=en-us&cc=us

 

If both new drives not detected in any of the drive slots then high chance that they are not HPE supported drives. Otherwise it's impossible that more than one slot of the Chassis is faulty.

 

 

Hope this helps!
Regards
Subhajit

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************************


Accept or Kudo
Shawn_K
HPE Pro

Re: P2000 G3 new hard disk problem

Hello,

You are correct in the fact your array firmware is old but that is likely not the issue. You should still update the array firmware to the latest version TS252P005.

All of your vdisks are FTIL (Fault Tolerant Online) so the new drives are not needed as spares for rebuilding.

Can you tell us what kind of drives you are trying to install? You would need to look at the physical drive and provide the drive type, size, and part number. If these drives are not HPE drives then the array will not recognize the drive since it likely does not have a drive firmware version that is compatable with the array.

Did you buy the drives from HPE?

 

Cheers,

Shawn

Accept or Kudo