MSA Storage

Problem with SSH/TELNET connection to MSA 2040

 
Martin_Kubes
Occasional Visitor

Problem with SSH/TELNET connection to MSA 2040

Hi, I tried connect to HP MSA 2040 via SSH or TELNET interface. HTTP and HTTPs inteface running well and I have right settings of user permissions (manage role, CLI and SSH enabled). 

I tried connect from Win10 (CMD + TELNET), Win10 (PuTTY), Win2012 R2 (PuTTY and CMD + TELNET) and from Linux CentOS 7 (Command line with ssh command). Every time I receive this message:

"/home/appuser/appshell: line 34: mccli: Input/outpur error"

and connection is closed by remote host.

I think, that is something wrong or not set on storage HP MSA 2040. Could You help me, please, with advice?

Thank You 

Regards Martin Kubeš

6 REPLIES 6
iamjawad
Advisor

Re: Problem with SSH/TELNET connection to MSA 2040

Hello,

 

Give me the output for below command

“Show protocol”

 

-JD

Martin_Kubes
Occasional Visitor

Re: Problem with SSH/TELNET connection to MSA 2040

Hi, here si log for telnet connection. There is only error message, not more :-(.

****************************************************

System Version: GL210R004
MC Version: GLM210R007-01
Serial Number: 00C0FF268F1A
10.0.20.118 login: adm
Password:
/home/appuser/appshell: line 34: mccli: Input/output error

*****************************************************

Regards Martin

Ahmed_Aljiledi
Occasional Advisor

Re: Problem with SSH/TELNET connection to MSA 2040

Hello Martin_Kubes ,

did you resolve your issue ? i have a same problem.

Dardan
Valued Contributor

Re: Problem with SSH/TELNET connection to MSA 2040

Hi,

I would suggest to use Putty as SSH/SFTP client to connect to your array (instad of CMD>Telnet of Windows). Also make sure 1° the required services are active from the SMU and that 2) the userID as the permissions to use them.

Bonus question: Are you using LDAP to connect to your array? If yes, then unecure protocols (Telnet / FTP) will be disabled.

Cheers,
Dardan

___________
Hit the Kudo's button to show appreciation or mark as solution if your question was answered.
Shawn_K
HPE Pro

Re: Problem with SSH/TELNET connection to MSA 2040

Hello,

You need to upgrade your system. GL210 firmware is not an active version of firmware. You can check the current firmware at the following site.

https://h41111.www4.hpe.com/storage/msafirmware.html

There have been many fixes and enhancements to the CLI, user names and passwords, and locales made in current firwmare since GL210.

Cheers,
Shawn

I work for Hewlett Packard Enterprise. The comments in this post are my own and do not represent an official reply from HPE. No warranty or guarantees of any kind are expressed in my reply.

 


I work for HPE

Accept or Kudo

jt_wtbts
New Member

Re: Problem with SSH/TELNET connection to MSA 2040

We have seen this many times with our MSA's. This is an issue with the older firmware. It seems the OS gets corrupted.

Unfortunately, we have not found a way to recover the controller, as you cannot login by any means.

We have always had to get a replacement controller from HP. Then once the controller is installed and synced to the active controllers FW, we immediately upgrade to a GL250 FW version to avoid this from happening again.

I am curious if using the 3.5mm COM ports (service only ports) there may be a secret way to recover, but we have not tried this yet.