MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

SAN Access Modules to StorageWorks SAN 16 Switch

 
Musso_1
Occasional Advisor

SAN Access Modules to StorageWorks SAN 16 Switch

Hi all,

I have a working test lab setup with the following;

• Compaq StorageWorks SAN 16 Switch
• 3 x Compaq RA4100 RAID Arrays
• 2 x Compaq ProLiant DL580 G1 Servers.

The servers both have 1 x Compaq Smart Array 5300, 256MB Cache and both fitted with newly purchased SAN Access Modules. Previously, everything worked prior to purchasing the SAN Access Modules. I used to have the servers connected via Compaq PCI Fibre Channel Cards and those connected to the SAN Switch with no problems at all. All could connect to the RA4100's with a combination of Alias/Zoning and SSP on the boxes as required.

Recently I read that the RA4100 could also work within a VMware 3.5 framework (although not officially supported of course) if used with the SAN Access Modules connected to the Smart Array Controllers. I have ensured all the firmware Is up to date on the controllers, Server BIOS, SAN Switch etc.

Here's the problem:
When switched on, the servers will just not consistently connect to the Switch. The really annoying thing is that it HAS done it a few times! I checked at which stage the lights went green and this was generally as the RAID card was initializing. More often than not though, the lights on the modules and switch are constantly negotiating (?) flashing orange.
Whilst connection was up, I actually managed to install VMware 3.5, with the RA4100 RAID Arrays even being seen as storage available for utilisation. It even survived a reboot and via VC I provisioned all the LUNS successfully with no problems at all.
The problem seems to be the communication from SAN Access Module to Switch. Just to note, I had previously removed all zoning and SSP so that would not cause any problems.

Do I need to set any specific parameters on the Switch To obtain consistent communication? I have read as many docs as I could get hold of pertaining to the Access Modules but cannot find much info regarding this.

I have tried powering down the servers and restarting, and the same with the SAN Switch - still nothing. Does anyone know of a SAN Switch or indeed HUB that definitely works with the SAN Access Modules? I am thinking this is a Switch issue.

This is not a critical thing, just something I would love to get working If I can.

Kind regards
Sean
2 REPLIES 2
Phil West
Occasional Advisor

Re: SAN Access Modules to StorageWorks SAN 16 Switch

The RA4100 is a loop device and I imagine that the SAN access modules are as well, so you can try force your switch ports into L ports & that may do it... or try a fc hub.
Musso_1
Occasional Advisor

Re: SAN Access Modules to StorageWorks SAN 16 Switch

Wow Phil, I had forgotten I had even posted this, it's been so long! :-)

The solution as you rightly said was to use a fibre channel hub - and that worked straight away flawlessly. I had tried every option on the switch and was very intermittant, sometimes it did work other times not, so I just decided to try a fc hub (cheap on ebay) and it worked first time and every time since.

Thanks for replying anyway, I should have closed this a long time ago.

Best wishes
Sean