MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

SAN Switch Configuration

 
Dean_Phelps
Occasional Contributor

SAN Switch Configuration

Could there be somthing wrong with the way in which I'm configuring my SAN switches, Storage Works 4/16. I have a couple of ports that display both a green light and an amber light. I believe that these ports are connected to FC1143 4 GB PCI HBAs. The HBAs only display an amber light as well. However, data is being transferred and the QLogic SANSurfer utility states the HBAs are good. I do have a SAN maintenance contract if you think this is an issue I should open up with a HP Engineer.
4 REPLIES 4
Uwe Zessin
Honored Contributor

Re: SAN Switch Configuration

Difficult to say.
Different components have different ways of how to show a status or an error. An amber light (off, blink, flash, steady) does NOT always mean something is wrong. You really need to consult the device's manual.
.
Mark...
Honored Contributor

Re: SAN Switch Configuration

Hi,
From the limited information you have given then there are a couple of things I would suggest you check:

I believe the 4/16 has two banks or 8 ports that are one above the other. The LEDS are underneath the PAIR of ports. Therefore when you look at the LEDS underneath the bottom port of the pair the LEDs are for both ports but you have to look to see whichone is for which port. I believe green = 4gb & amber = 2gb set or selected but I don't have a service guide to hand to check.

So, have you got other cables connected to other HBA's above/below the ports that you have mentioned ??? or are they empty ?? If so then this could be the "problem".

You could also log onto the switch itself & check the port settings. I believe that "switchshow" should show you all the ports and there current speeds.

I have not used SANsurfer either but does the display tell you the speed of the connection ?? You could be at 2gb and all is OK ! because data is being transferred.

You would then not see a potential issue until you suspected that your performace was a bit slow.

Summary:
Verify that your cabling to make sure that cables go to where you think they should go
Check your ports & LEDS with service guide
Check speeds of ports from switch, modify if required

Mark...
if you have nothing useful to say, say nothing...

Re: SAN Switch Configuration

Well, I'm not familiar with the lights on the HBA, but the lights are fine for a 4 Gb connection on a Storage Works 4/16 switch. Get a copy of the manual (.PDF) and read the lights' tables.
Personally, I have always thought using the amber color to indicate a 4 Gb connection speed (off: 1Gb, green: 2Gb, amber: 4Gb) was not one of the better ideas Brocade had with their switches.

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Mark...
Honored Contributor

Re: SAN Switch Configuration

Ah well, the 4/16 service manual can be found here:
http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00498167/c00498167.pdf
with the LED status on page 62.

Mark...
if you have nothing useful to say, say nothing...