MSA Storage

SAS problem MSA2000 G3

 
SOLVED
Go to solution
HanCas
Valued Contributor

SAS problem MSA2000 G3

Hi,

We had a power problem in enclosure 3 of our MSA2000 G3

After replacement of the power, we now have an issue with the SAS cannels

We see the following

Unhealthy Component
-------------------
Component ID: Enclosure 4, Expansion Module B, Out Expansion Port
Health: Degraded
Health Reason: The enclosure expansion port is degraded; some, but not all, of the PHY lanes can support activity.
Health Recommendation: - Check the SAS expansion cable between enclosures connected through the indicated port, and replace the cable if necessary.\n- If this does not correct the problem, check that the modules at each end of the cable are powered up and have good health; replace any faulty controller module or expansion module.

Unhealthy Component
-------------------
Component ID: Enclosure 3, Expansion Module A, In Expansion Port
Health: Degraded
Health Reason: The enclosure expansion port is degraded; some, but not all, of the PHY lanes can support activity.
Health Recommendation: - Check the SAS expansion cable between enclosures connected through the indicated port, and replace the cable if necessary.\n- If this does not correct the problem, check that the modules at each end of the cable are powered up and have good health; replace any faulty controller module or expansion module.

Unhealthy Component
-------------------
Component ID: Enclosure 3, Expansion Module B, In Expansion Port
Health: Degraded
Health Reason: The enclosure expansion port is degraded; some, but not all, of the PHY lanes can support activity.
Health Recommendation: - Check the SAS expansion cable between enclosures connected through the indicated port, and replace the cable if necessary.\n- If this does not correct the problem, check that the modules at each end of the cable are powered up and have good health; replace any faulty controller module or expansion module.

Unhealthy Component
-------------------
Component ID: Enclosure 2, Expansion Module A, Out Expansion Port
Health: Degraded
Health Reason: The enclosure expansion port is degraded; some, but not all, of the PHY lanes can support activity.
Health Recommendation: - Check the SAS expansion cable between enclosures connected through the indicated port, and replace the cable if necessary.\n- If this does not correct the problem, check that the modules at each end of the cable are powered up and have good health; replace any faulty controller module or expansion module.

So, on enclosure 3 both IN ports on the IOMS are 'faulty' and on enclosure 4 one SAS OUT port and on Enclosure one SAS OUT port (but on the other side). This would imply enclosure 3 cannot be properly reached, but the MSA seems to be working fine.

If we look further down on the log we see the following

U12-6G Degraded A subcomponent of this component is unhealthy. - No action is required. for enclosure 2, 3 and  4.

What could be causing this please. We have reseated the SAS cables

.
2 REPLIES 2
Shawn_K
HPE Pro
Solution

Re: SAS problem MSA2000 G3

Hello,

Due to the power issue you may have either caused the backend SAS map to be rebuilt or incorrectly scanned. There are a couple of things you can try.

Check and verify the cables are correctly seated. I have seen where work is done in the rack and bumping a SAS cable has caused a loss of the path or disconnected an enclosure.

Or try the following:

  • Stop all host I/O
  • Correctly shutdown the controllers and power down the array.
  • Remove all power cords to all enclosures allowing the drives to spin down
  • Check the backend SAS cables to ensure they are correctly connected between enclosures and firmly seated
  • Power on the enclsoures in the correct order starting at the last/bottom enclosure unitl you reach the controller enclosure
  • In the CLI issue the following command: rescan <enter>

This will rebuild your backend SAS map. If the issue persists you may want to log a support case and have the logs reviewed or IOMs replaced.

Cheers,
Shawn

I work for Hewlett Packard Enterprise. The comments in this post are my own and do not represent an official reply from HPE. No warranty or guarantees of any kind are expressed in my reply.


I work for HPE

Accept or Kudo

HanCas
Valued Contributor

Re: SAS problem MSA2000 G3

gehter with HPE we isolated the problem

On two IO Modules we found a SAS channel being disabled due to internal errors, so instead of 4 active channels per port there were only 3. One module had an issue on channel 3 on the Ingress port the other on channel 0 on the Egress port.
Both IO modules will be replaced.

This is visivble in the config log,

.