MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Path 3.0D issues on Solaris 8

 
CA1004210
Frequent Advisor

Secure Path 3.0D issues on Solaris 8

Hi All,

Brief description of the setup:
A Sun Solaris 8 host connected to EVA 5000 with dual FCA2257P HBAs running Secure Path V3.0D

Secure Path V3.0D was successfully installed on the host.After the install, only three paths to the LUNs on the EVA were seen as one of the fibre channel cables (connecting FP2 of the bottom controller to a port on one of the fabric switches) was not installed.

I installed the missing fibre channel cable hoping that Secure Path would automatically detect the new path throughs its path verification mechanism and "spmgr display" should see 4 paths for each LUN. This did not happen even after a reboot. I ran drvconfig - no success, devfsadm - no success, config.sh to manually remove and add adapters - no success. On a subsequent reboot, the host did not see any LUNs at all and halted in single user mode trying to mount the filesystem on non-existing LUNs.

LUNs are still being presented to the host from the EVA end and zoning configuration is as expected.

Any clue anyone?

Regards,
1 REPLY 1
CA1264505
Occasional Visitor

Re: Secure Path 3.0D issues on Solaris 8

Hi,

I'm not sure whether your problem with the missing path is solved, but check /kernel/drv/swsp.conf
Iguess you should have four wwlid entries.

I had a similar problem installing SecurePath on Solaris8 when zoning was not done yet, and ended up where you did: paths were not seen.
After diging some time I found that those wwlid entries were missing (therefore the swsp module was not loaded into the kernel), /dev/swsp was not created, etc.
After including the entries and data regarding EVA and rebooting, everything worked as expected.

best regards, Attila